summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-04-28 02:32:55 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-04-28 02:32:55 +0000
commit96ea2bb75c3427837508e816f61396d6c543477a (patch)
tree78b6be9a821901e1cf1ca854ee060b96fcbb4ef7 /dev-python/hp3parclient
parentVersion bump. (diff)
downloadgentoo-2-96ea2bb75c3427837508e816f61396d6c543477a.tar.gz
gentoo-2-96ea2bb75c3427837508e816f61396d6c543477a.tar.bz2
gentoo-2-96ea2bb75c3427837508e816f61396d6c543477a.zip
more for cinder
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/hp3parclient')
-rw-r--r--dev-python/hp3parclient/ChangeLog10
-rw-r--r--dev-python/hp3parclient/hp3parclient-3.0.0.ebuild37
2 files changed, 45 insertions, 2 deletions
diff --git a/dev-python/hp3parclient/ChangeLog b/dev-python/hp3parclient/ChangeLog
index 6a555ba7e553..6b1f1a0869b8 100644
--- a/dev-python/hp3parclient/ChangeLog
+++ b/dev-python/hp3parclient/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/hp3parclient
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/hp3parclient/ChangeLog,v 1.2 2013/12/18 10:11:20 idella4 Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/hp3parclient/ChangeLog,v 1.3 2014/04/28 02:32:55 prometheanfire Exp $
+
+*hp3parclient-3.0.0 (28 Apr 2014)
+
+ 28 Apr 2014; Matthew Thode <prometheanfire@gentoo.org>
+ +hp3parclient-3.0.0.ebuild:
+ more for cinder
18 Dec 2013; Ian Delaney <idella4@gentoo.org> hp3parclient-2.0.0.ebuild:
Add missing dep for doc build
diff --git a/dev-python/hp3parclient/hp3parclient-3.0.0.ebuild b/dev-python/hp3parclient/hp3parclient-3.0.0.ebuild
new file mode 100644
index 000000000000..87f7a5fcf349
--- /dev/null
+++ b/dev-python/hp3parclient/hp3parclient-3.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/hp3parclient/hp3parclient-3.0.0.ebuild,v 1.1 2014/04/28 02:32:55 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A python interface to sendfile(2) system call"
+HOMEPAGE="http://packages.python.org/hp3parclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND=">=dev-python/httplib2-0.6.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/eventlet[${PYTHON_USEDEP}]
+ test? ( dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/nose-testconfig[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+# Instructions on running tests are utter nonsense. Tried and gave up
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( samples/. )
+ distutils-r1_python_install_all
+}