summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2011-08-27 21:00:30 +0000
committerJesus Rivero <neurogeek@gentoo.org>2011-08-27 21:00:30 +0000
commit515bdba6df3b8603c55a2945765e6e7739864363 (patch)
treea8c583211f5577eab7126985bfe74c3ecfb54236 /dev-python/git-python
parentMarked stable on AMD64 based on arch testing by Elijah El Lazkani & Agostino ... (diff)
downloadgentoo-2-515bdba6df3b8603c55a2945765e6e7739864363.tar.gz
gentoo-2-515bdba6df3b8603c55a2945765e6e7739864363.tar.bz2
gentoo-2-515bdba6df3b8603c55a2945765e6e7739864363.zip
Added dev-python/gitdb to DEPEND
(Portage version: 2.2.0_alpha46/cvs/Linux i686)
Diffstat (limited to 'dev-python/git-python')
-rw-r--r--dev-python/git-python/ChangeLog6
-rw-r--r--dev-python/git-python/git-python-0.3.2_rc1.ebuild7
2 files changed, 10 insertions, 3 deletions
diff --git a/dev-python/git-python/ChangeLog b/dev-python/git-python/ChangeLog
index fd707c744d69..e12e1fe54840 100644
--- a/dev-python/git-python/ChangeLog
+++ b/dev-python/git-python/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/git-python
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/git-python/ChangeLog,v 1.7 2011/08/27 14:24:18 zorry Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/git-python/ChangeLog,v 1.8 2011/08/27 21:00:30 neurogeek Exp $
+
+ 27 Aug 2011; Jesus Rivero <neurogeek@gentoo.org>
+ git-python-0.3.2_rc1.ebuild:
+ Added dev-python/gitdb to DEPEND
*git-python-0.3.2_rc1 (27 Aug 2011)
diff --git a/dev-python/git-python/git-python-0.3.2_rc1.ebuild b/dev-python/git-python/git-python-0.3.2_rc1.ebuild
index 5bfd7a004c98..67df264bb467 100644
--- a/dev-python/git-python/git-python-0.3.2_rc1.ebuild
+++ b/dev-python/git-python/git-python-0.3.2_rc1.ebuild
@@ -1,15 +1,17 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/git-python/git-python-0.3.2_rc1.ebuild,v 1.1 2011/08/27 14:24:18 zorry Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/git-python/git-python-0.3.2_rc1.ebuild,v 1.2 2011/08/27 21:00:30 neurogeek Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
+#Tests dont make sense without a git repo
+#DISTUTILS_SRC_TESTS="nosetests"
inherit distutils
MY_PN="GitPython"
-MY_PV=${PV/_rc/.RC}
+MY_PV="${PV/_rc/.RC}"
MY_P="${MY_PN}-${MY_PV}"
DESCRIPTION="GitPython is a python library used to interact with Git repositories."
@@ -23,6 +25,7 @@ IUSE=""
RDEPEND="dev-vcs/git"
DEPEND="${RDEPEND}
+ >=dev-python/gitdb-0.5.4
dev-python/setuptools"
RESTRICT_PYTHON_ABIS="3.*"