summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-16 08:14:30 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-16 08:14:30 +0000
commitf13c68dc8260f8d9ee7631e1d15ff306e0fbc560 (patch)
tree5cee02be463874389181f595c2d4d79009ac2fc5 /dev-python/gdata
parentAdd myself as maintainer for www-apps/trac. (diff)
downloadgentoo-2-f13c68dc8260f8d9ee7631e1d15ff306e0fbc560.tar.gz
gentoo-2-f13c68dc8260f8d9ee7631e1d15ff306e0fbc560.tar.bz2
gentoo-2-f13c68dc8260f8d9ee7631e1d15ff306e0fbc560.zip
Version bump.
(Portage version: 14609-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/gdata')
-rw-r--r--dev-python/gdata/ChangeLog9
-rw-r--r--dev-python/gdata/files/gdata-1.0.8-test-fix.patch81
-rw-r--r--dev-python/gdata/gdata-1.0.8.ebuild47
-rw-r--r--dev-python/gdata/gdata-2.0.1.ebuild47
-rw-r--r--dev-python/gdata/gdata-2.0.4.ebuild (renamed from dev-python/gdata/gdata-2.0.1-r1.ebuild)14
5 files changed, 13 insertions, 185 deletions
diff --git a/dev-python/gdata/ChangeLog b/dev-python/gdata/ChangeLog
index 5653a31219ef..6d3ead39e47f 100644
--- a/dev-python/gdata/ChangeLog
+++ b/dev-python/gdata/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/gdata
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gdata/ChangeLog,v 1.38 2009/10/12 19:25:26 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gdata/ChangeLog,v 1.39 2009/10/16 08:14:30 arfrever Exp $
+
+*gdata-2.0.4 (16 Oct 2009)
+
+ 16 Oct 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -gdata-1.0.8.ebuild, -files/gdata-1.0.8-test-fix.patch,
+ -gdata-2.0.1.ebuild, -gdata-2.0.1-r1.ebuild, +gdata-2.0.4.ebuild:
+ Version bump.
12 Oct 2009; Jeroen Roovers <jer@gentoo.org> gdata-2.0.2.ebuild:
Stable for HPPA (bug #287194).
diff --git a/dev-python/gdata/files/gdata-1.0.8-test-fix.patch b/dev-python/gdata/files/gdata-1.0.8-test-fix.patch
deleted file mode 100644
index 4ff4de0c3f66..000000000000
--- a/dev-python/gdata/files/gdata-1.0.8-test-fix.patch
+++ /dev/null
@@ -1,81 +0,0 @@
---- gdata.py-1.0.8/tests/atom/service_test.py 2007-07-21 00:25:54.000000000 +0300
-+++ gdata.py-1.0.8/tests/atom/service_test.py 2008-03-28 08:40:16.044330089 +0200
-@@ -69,7 +69,7 @@
- self.assertEquals(ssl, False)
- self.assertEquals(host, 'www.google.com')
- self.assertEquals(port, 80)
-- self.assertEquals(path, 'http://www.google.com:80/service/subservice?name=value')
-+ self.assertEquals(path, '/service/subservice?name=value')
-
- def testParseHttpUrlWithPort(self):
- as = atom.service.AtomService('code.google.com')
-@@ -81,7 +81,7 @@
- self.assertEquals(host, 'www.google.com')
- self.assertEquals(port, 12)
- #self.assertEquals(path, '/service/subservice?name=value&newname=newvalue')
-- self.assertEquals(path, 'http://www.google.com:12/service/subservice?name=value&newname=newvalue')
-+ self.assertEquals(path, '/service/subservice?name=value&newname=newvalue')
-
- def testParseHttpsUrl(self):
- as = atom.service.AtomService('code.google.com')
-@@ -92,7 +92,7 @@
- self.assertEquals(ssl, True)
- self.assertEquals(host, 'www.google.com')
- self.assertEquals(port, 443)
-- self.assertEquals(path, 'https://www.google.com:443/service/subservice?name=value&newname=newvalue')
-+ self.assertEquals(path, '/service/subservice?name=value&newname=newvalue')
-
- def testParseHttpsUrlWithPort(self):
- as = atom.service.AtomService('code.google.com')
-@@ -103,50 +103,8 @@
- self.assertEquals(ssl, True)
- self.assertEquals(host, 'www.google.com')
- self.assertEquals(port, 13981)
-- self.assertEquals(path, 'https://www.google.com:13981/service/subservice?name=value&newname=newvalue')
-+ self.assertEquals(path, '/service/subservice?name=value&newname=newvalue')
-
-- def testParseUrlWithFullProxyURL(self):
-- as = atom.service.AtomService('code.google.com')
-- as.proxy_url = 'https://proxy.example.com:8080'
-- self.assert_(as.server == 'code.google.com')
-- self.assert_(as.proxy_url == 'https://proxy.example.com:8080')
-- (host, port, ssl, path) = as._ProcessUrl(
-- 'http://www.google.com:13981/service/subservice?name=value&newname=newvalue')
-- self.assertEquals(ssl, True)
-- self.assertEquals(host, 'proxy.example.com')
-- self.assertEquals(port, 8080)
-- self.assertEquals(path, 'http://www.google.com:13981/service/subservice?name=value&newname=newvalue')
--
-- def testParseUrlWithHostOnlyProxyURL(self):
-- as = atom.service.AtomService('code.google.com')
-- as.proxy_url = 'http://proxy.example.com'
-- self.assert_(as.server == 'code.google.com')
-- self.assert_(as.proxy_url == 'http://proxy.example.com:80')
-- (host, port, ssl, path) = as._ProcessUrl(
-- 'https://www.google.com/service/subservice')
-- self.assertEquals(ssl, False)
-- self.assertEquals(host, 'proxy.example.com')
-- self.assertEquals(port, 80)
-- self.assertEquals(path, 'https://www.google.com:443/service/subservice')
--
-- def testSetProxyUrlToIllegalValues(self):
-- as = atom.service.AtomService('code.google.com')
-- try:
-- as.proxy_url = 'proxy.example.com'
-- self.fail('A URL with no protocol should trigger InvalidProxyUrl')
-- except atom.service.InvalidProxyUrl:
-- pass
-- try:
-- as.proxy_url = 'http://:80'
-- self.fail('A URL with no server should trigger InvalidProxyUrl')
-- except atom.service.InvalidProxyUrl:
-- pass
-- try:
-- as.proxy_url = 'http://'
-- self.fail('A URL with only the protocol should trigger InvalidProxyUrl')
-- except atom.service.InvalidProxyUrl:
-- pass
--
- def testSetBasicAuth(self):
- client = atom.service.AtomService()
- client.UseBasicAuth('foo', 'bar')
diff --git a/dev-python/gdata/gdata-1.0.8.ebuild b/dev-python/gdata/gdata-1.0.8.ebuild
deleted file mode 100644
index da297fdca57b..000000000000
--- a/dev-python/gdata/gdata-1.0.8.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gdata/gdata-1.0.8.ebuild,v 1.15 2009/04/28 12:02:25 armin76 Exp $
-
-inherit distutils eutils
-
-MY_P="gdata.py-${PV}"
-
-DESCRIPTION="Python client library for Google data APIs"
-HOMEPAGE="http://code.google.com/p/gdata-python-client/"
-SRC_URI="http://gdata-python-client.googlecode.com/files/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="examples"
-
-DEPEND=""
-RDEPEND="|| ( >=dev-lang/python-2.5 dev-python/elementtree )"
-
-PYTHON_MODNAME="atom gdata"
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- distutils_src_unpack
-
- epatch "${FILESDIR}/${P}-test-fix.patch"
-}
-
-src_install() {
- distutils_src_install
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r samples
- fi
-}
-
-src_test() {
- cd tests
- export PYTHONPATH=../src
- for x in $(find -name "*.py"); do
- grep -q raw_input ${x} && continue
- einfo "Running ${x}..."
- "${python}" ${x} -v || die "${x} failed"
- done
-}
diff --git a/dev-python/gdata/gdata-2.0.1.ebuild b/dev-python/gdata/gdata-2.0.1.ebuild
deleted file mode 100644
index 8d8c356398b7..000000000000
--- a/dev-python/gdata/gdata-2.0.1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gdata/gdata-2.0.1.ebuild,v 1.3 2009/09/22 19:33:45 arfrever Exp $
-
-EAPI="2"
-
-inherit distutils eutils
-
-MY_P="gdata-${PV}"
-
-DESCRIPTION="Python client library for Google data APIs"
-HOMEPAGE="http://code.google.com/p/gdata-python-client/"
-SRC_URI="http://gdata-python-client.googlecode.com/files/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="examples"
-
-DEPEND=""
-RDEPEND="|| ( >=dev-lang/python-2.5 dev-python/elementtree )"
-
-PYTHON_MODNAME="atom gdata"
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- distutils_src_prepare
- epatch "${FILESDIR}/${PN}-2.0.2-fix_tests.patch"
-}
-
-src_test() {
- cd tests
- export PYTHONPATH=../src
- "${python}" run_data_tests.py -v || die "Data tests failed"
-
- # run_service_tests.py requires interaction (and a valid google account), so skip.
- #"${python}" run_service_tests.py -v || die "Service tests failed"
-}
-
-src_install() {
- distutils_src_install
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r samples
- fi
-}
diff --git a/dev-python/gdata/gdata-2.0.1-r1.ebuild b/dev-python/gdata/gdata-2.0.4.ebuild
index 1fbd184c853d..2cd79724f33e 100644
--- a/dev-python/gdata/gdata-2.0.1-r1.ebuild
+++ b/dev-python/gdata/gdata-2.0.4.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gdata/gdata-2.0.1-r1.ebuild,v 1.2 2009/09/22 19:33:45 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gdata/gdata-2.0.4.ebuild,v 1.1 2009/10/16 08:14:30 arfrever Exp $
EAPI="2"
+NEED_PYTHON="2.5"
SUPPORT_PYTHON_ABIS="1"
inherit distutils eutils
@@ -19,17 +20,12 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="examples"
DEPEND=""
-RDEPEND="|| ( >=dev-lang/python-2.5 dev-python/elementtree )"
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
-RESTRICT_PYTHON_ABIS="3*"
-
-PYTHON_MODNAME="atom gdata"
S="${WORKDIR}/${MY_P}"
-src_prepare() {
- distutils_src_prepare
- epatch "${FILESDIR}/${PN}-2.0.2-fix_tests.patch"
-}
+PYTHON_MODNAME="atom gdata"
src_test() {
testing() {