summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2009-07-13 22:03:19 +0000
committerJesus Rivero <neurogeek@gentoo.org>2009-07-13 22:03:19 +0000
commitc7d58c658e15ae0261bb8eff102c431593158a77 (patch)
treeea1e5a7da009bfc2d69a81ecb330f0a248282bc2 /dev-python/fusil
parentAdded patch to make Jinja2 compile with doc USE flag. Closes bug #277462. Tha... (diff)
downloadgentoo-2-c7d58c658e15ae0261bb8eff102c431593158a77.tar.gz
gentoo-2-c7d58c658e15ae0261bb8eff102c431593158a77.tar.bz2
gentoo-2-c7d58c658e15ae0261bb8eff102c431593158a77.zip
Added USE flags for doc and examples. Closes bug #263582. Thanks to August for the patch.
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'dev-python/fusil')
-rw-r--r--dev-python/fusil/ChangeLog8
-rw-r--r--dev-python/fusil/fusil-1.2.1-r1.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-python/fusil/ChangeLog b/dev-python/fusil/ChangeLog
index 7c55b29bda03..7a872cfbcee5 100644
--- a/dev-python/fusil/ChangeLog
+++ b/dev-python/fusil/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/fusil
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/fusil/ChangeLog,v 1.1 2009/02/28 19:40:44 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fusil/ChangeLog,v 1.2 2009/07/13 22:03:19 neurogeek Exp $
+
+*fusil-1.2.1-r1 (13 Jul 2009)
+
+ 13 Jul 2009; Jesus Rivero <neurogeek@gentoo.org> +fusil-1.2.1-r1.ebuild:
+ Added USE flags for doc and examples. Closes bug #263582. Thanks to August
+ for the patch.
*fusil-1.2.1 (28 Feb 2009)
diff --git a/dev-python/fusil/fusil-1.2.1-r1.ebuild b/dev-python/fusil/fusil-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..ce873c8702c5
--- /dev/null
+++ b/dev-python/fusil/fusil-1.2.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fusil/fusil-1.2.1-r1.ebuild,v 1.1 2009/07/13 22:03:19 neurogeek Exp $
+
+EAPI="2"
+NEED_PYTHON=2.4
+
+inherit distutils
+
+DESCRIPTION="Fusil the fuzzer is a Python library used to write fuzzing programs."
+HOMEPAGE="http://fusil.hachoir.org/"
+SRC_URI="http://pypi.python.org/packages/source/f/fusil/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+DEPEND="|| ( ( =dev-lang/python-2.4* dev-python/ctypes ) >=dev-lang/python-2.5 )"
+RDEPEND="dev-python/python-ptrace"
+
+PYTHON_MODNAME="fusil"
+
+src_install(){
+ distutils_src_install
+
+ if use doc; then
+ DOCS="doc/*"
+ fi
+
+ if use examples; then
+ insinto "/usr/share/doc/${PF}"
+ doins -r examples
+ fi
+
+}
+
+pkg_postinst() {
+ enewgroup fusil
+ enewuser fusil -1 -1 -1 "fusil"
+}