summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2012-11-15 14:23:34 +0000
committerIan Delaney <idella4@gentoo.org>2012-11-15 14:23:34 +0000
commit4c09d70e77d25d0d364504143b660158aa28dba2 (patch)
tree21639e6e524f0f2b1f3ff275decd1e731dbe948b /dev-python/flask-sqlalchemy
parentfix proxy maintainers email (diff)
downloadgentoo-2-4c09d70e77d25d0d364504143b660158aa28dba2.tar.gz
gentoo-2-4c09d70e77d25d0d364504143b660158aa28dba2.tar.bz2
gentoo-2-4c09d70e77d25d0d364504143b660158aa28dba2.zip
Bump, -0.16, thanks to patch from J. Bergstrom, closes Bug #415123
(Portage version: 2.1.11.30/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/flask-sqlalchemy')
-rw-r--r--dev-python/flask-sqlalchemy/ChangeLog10
-rw-r--r--dev-python/flask-sqlalchemy/flask-sqlalchemy-0.16.ebuild36
2 files changed, 43 insertions, 3 deletions
diff --git a/dev-python/flask-sqlalchemy/ChangeLog b/dev-python/flask-sqlalchemy/ChangeLog
index 678f32fcf1a6..6335f9b215e2 100644
--- a/dev-python/flask-sqlalchemy/ChangeLog
+++ b/dev-python/flask-sqlalchemy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/flask-sqlalchemy
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-sqlalchemy/ChangeLog,v 1.7 2011/09/08 07:13:52 rafaelmartins Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-sqlalchemy/ChangeLog,v 1.8 2012/11/15 14:23:34 idella4 Exp $
+
+*flask-sqlalchemy-0.16 (16 Nov 2012)
+
+ 16 Nov 2012; Ian Delaney <idella4@gentoo.org> +flask-sqlalchemy-0.16.ebuild:
+ Bump, -0.16, thanks to patch from J. Bergstrom, closes Bug #415123
*flask-sqlalchemy-0.15 (08 Sep 2011)
@@ -38,4 +43,3 @@
+flask-sqlalchemy-0.6.ebuild, +metadata.xml:
Package needed for grumpy SoC project. Ebuild by Priit Laes
<plaes@plaes.org>.
-
diff --git a/dev-python/flask-sqlalchemy/flask-sqlalchemy-0.16.ebuild b/dev-python/flask-sqlalchemy/flask-sqlalchemy-0.16.ebuild
new file mode 100644
index 000000000000..6e98d8c3816c
--- /dev/null
+++ b/dev-python/flask-sqlalchemy/flask-sqlalchemy-0.16.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-sqlalchemy/flask-sqlalchemy-0.16.ebuild,v 1.1 2012/11/15 14:23:34 idella4 Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+MY_PN="Flask-SQLAlchemy"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="SQLAlchemy support for Flask applications"
+HOMEPAGE="http://pypi.python.org/pypi/Flask-SQLAlchemy"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/flask
+ dev-python/setuptools
+ dev-python/sqlalchemy"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="flask_sqlalchemy.py"
+
+src_prepare() {
+ sed -ie "s/flaskext/flask.ext/" test.py || die
+}