summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-01-22 11:58:45 +0000
committerIan Delaney <idella4@gentoo.org>2013-01-22 11:58:45 +0000
commit3136d50ec1d440d7af10f898a8aae0a4dd8de7bc (patch)
tree700c65d3d0a11e11a0605b2331f0b76d33927cbb /dev-python/flask-script
parentUpdate ebuild basics and change usb-load-ehci-first.conf modprobe.d install p... (diff)
downloadgentoo-2-3136d50ec1d440d7af10f898a8aae0a4dd8de7bc.tar.gz
gentoo-2-3136d50ec1d440d7af10f898a8aae0a4dd8de7bc.tar.bz2
gentoo-2-3136d50ec1d440d7af10f898a8aae0a4dd8de7bc.zip
bump
(Portage version: 2.1.11.40/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/flask-script')
-rw-r--r--dev-python/flask-script/ChangeLog9
-rw-r--r--dev-python/flask-script/flask-script-0.5.3.ebuild44
2 files changed, 51 insertions, 2 deletions
diff --git a/dev-python/flask-script/ChangeLog b/dev-python/flask-script/ChangeLog
index ef4e4b48b223..dd6e1f04acc3 100644
--- a/dev-python/flask-script/ChangeLog
+++ b/dev-python/flask-script/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/flask-script
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-script/ChangeLog,v 1.7 2012/11/17 21:46:16 floppym Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-script/ChangeLog,v 1.8 2013/01/22 11:58:45 idella4 Exp $
+
+*flask-script-0.5.3 (22 Jan 2013)
+
+ 22 Jan 2013; Ian Delaney <idella4@gentoo.org> +flask-script-0.5.3.ebuild:
+ bump
17 Nov 2012; Mike Gilbert <floppym@gentoo.org> flask-script-0.5.1.ebuild:
Set PYTHON_MODNAME=flask_script.py. Bug 443486 by mreug.
diff --git a/dev-python/flask-script/flask-script-0.5.3.ebuild b/dev-python/flask-script/flask-script-0.5.3.ebuild
new file mode 100644
index 000000000000..2397f1efb6bd
--- /dev/null
+++ b/dev-python/flask-script/flask-script-0.5.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-script/flask-script-0.5.3.ebuild,v 1.1 2013/01/22 11:58:45 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+MY_PN="Flask-Script"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Flask support for writing external scripts."
+HOMEPAGE="http://packages.python.org/Flask-Script/ http://pypi.python.org/pypi/Flask-Script"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="dev-python/flask
+ virtual/python-argparse[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ if use doc; then
+ einfo "Generation of documentation by" ${PYTHON}
+ PYTHONPATH=".." emake -C docs html || die "Generation of documentation failed"
+ fi
+}
+
+python_test() {
+ nosetests -v || die
+}
+
+python_install_all() {
+ use doc && dohtml -r docs/_build/html/
+ dodoc README.rst
+}