summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-03-18 10:06:46 +0000
committerIan Delaney <idella4@gentoo.org>2014-03-18 10:06:46 +0000
commit4e1e5cb663d10a3d15ec0a1af52a4ab645761002 (patch)
treec25d04fbfe06d56df6e06aa7964051dcdd0dc33b /dev-python/django-social-auth
parentAdd RESTRICT="test", bug 504946. (diff)
downloadgentoo-2-4e1e5cb663d10a3d15ec0a1af52a4ab645761002.tar.gz
gentoo-2-4e1e5cb663d10a3d15ec0a1af52a4ab645761002.tar.bz2
gentoo-2-4e1e5cb663d10a3d15ec0a1af52a4ab645761002.zip
bump; add IUSE doc, examples, update deps, remove old
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/django-social-auth')
-rw-r--r--dev-python/django-social-auth/ChangeLog10
-rw-r--r--dev-python/django-social-auth/django-social-auth-0.7.23.ebuild27
-rw-r--r--dev-python/django-social-auth/django-social-auth-0.7.28.ebuild44
3 files changed, 52 insertions, 29 deletions
diff --git a/dev-python/django-social-auth/ChangeLog b/dev-python/django-social-auth/ChangeLog
index eb353edf93fc..995cb0692892 100644
--- a/dev-python/django-social-auth/ChangeLog
+++ b/dev-python/django-social-auth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/django-social-auth
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-social-auth/ChangeLog,v 1.4 2013/06/01 17:24:37 idella4 Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-social-auth/ChangeLog,v 1.5 2014/03/18 10:06:46 idella4 Exp $
+
+*django-social-auth-0.7.28 (18 Mar 2014)
+
+ 18 Mar 2014; Ian Delaney <idella4@gentoo.org>
+ +django-social-auth-0.7.28.ebuild, -django-social-auth-0.7.23.ebuild:
+ bump; add IUSE doc, examples, update deps, remove old
01 Jun 2013; Ian Delaney <idella4@gentoo.org>
django-social-auth-0.7.23.ebuild:
diff --git a/dev-python/django-social-auth/django-social-auth-0.7.23.ebuild b/dev-python/django-social-auth/django-social-auth-0.7.23.ebuild
deleted file mode 100644
index fea05d4925cf..000000000000
--- a/dev-python/django-social-auth/django-social-auth-0.7.23.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-social-auth/django-social-auth-0.7.23.ebuild,v 1.2 2013/06/01 17:24:37 idella4 Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7} )
-
-inherit distutils-r1
-
-DESCRIPTION="An easy to setup social authentication/authorization mechanism for Django projects"
-HOMEPAGE="http://pypi.python.org/pypi/django-social-auth/"
-SRC_URI="https://github.com/omab/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-LICENSE="BSD"
-SLOT="0"
-# Tests access and test logins to social media sites
-RESTRICT="test"
-
-RDEPEND=">=dev-python/django-1.3.2[${PYTHON_USEDEP}]
- >=dev-python/oauth2-1.5.170[${PYTHON_USEDEP}]
- >=dev-python/python-openid-2.2[${PYTHON_USEDEP}]
- >=dev-python/selenium-2.29.0[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/django-social-auth/django-social-auth-0.7.28.ebuild b/dev-python/django-social-auth/django-social-auth-0.7.28.ebuild
new file mode 100644
index 000000000000..b3100589c733
--- /dev/null
+++ b/dev-python/django-social-auth/django-social-auth-0.7.28.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-social-auth/django-social-auth-0.7.28.ebuild,v 1.1 2014/03/18 10:06:46 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="An easy to setup social authentication/authorization mechanism for Django projects"
+HOMEPAGE="http://pypi.python.org/pypi/django-social-auth/"
+SRC_URI="https://github.com/omab/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+LICENSE="BSD"
+SLOT="0"
+# Tests access and test logins to social media sites
+RESTRICT="test"
+
+RDEPEND=">=dev-python/django-1.2.5[${PYTHON_USEDEP}]
+ >=dev-python/oauth2-1.5.167[${PYTHON_USEDEP}]
+ >=dev-python/python-openid-2.2[${PYTHON_USEDEP}]
+ >=dev-python/selenium-2.29.0[${PYTHON_USEDEP}]
+ ~dev-python/mock-1.0.1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Prevent un-needed d'loading in doc build
+ sed -e 's:^intersphinx:_&:' -i doc/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ use examples && local EXAMPLES=( example/. )
+ distutils-r1_python_install_all
+}