summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-01-27 02:24:42 +0000
committerIan Delaney <idella4@gentoo.org>2014-01-27 02:24:42 +0000
commitfd553e1d2a64833a8ca1fe8b5c09885adeb0b840 (patch)
tree5af057448c7ecf18d7ea9bdc940cdc07d14e7b6a /dev-python/django-oauth-plus
parentUnmask =media-libs/portaudio-19_pre20140121_rc. (diff)
downloadgentoo-2-fd553e1d2a64833a8ca1fe8b5c09885adeb0b840.tar.gz
gentoo-2-fd553e1d2a64833a8ca1fe8b5c09885adeb0b840.tar.bz2
gentoo-2-fd553e1d2a64833a8ca1fe8b5c09885adeb0b840.zip
bump; update deps, test phase
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/django-oauth-plus')
-rw-r--r--dev-python/django-oauth-plus/ChangeLog9
-rw-r--r--dev-python/django-oauth-plus/django-oauth-plus-2.2.4.ebuild33
2 files changed, 40 insertions, 2 deletions
diff --git a/dev-python/django-oauth-plus/ChangeLog b/dev-python/django-oauth-plus/ChangeLog
index 8d9c5a34069a..8535693c1e06 100644
--- a/dev-python/django-oauth-plus/ChangeLog
+++ b/dev-python/django-oauth-plus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/django-oauth-plus
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-oauth-plus/ChangeLog,v 1.7 2013/10/02 06:12:16 patrick Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-oauth-plus/ChangeLog,v 1.8 2014/01/27 02:24:42 idella4 Exp $
+
+*django-oauth-plus-2.2.4 (27 Jan 2014)
+
+ 27 Jan 2014; Ian Delaney <idella4@gentoo.org> +django-oauth-plus-2.2.4.ebuild:
+ bump; update deps, test phase
*django-oauth-plus-2.1.5 (02 Oct 2013)
diff --git a/dev-python/django-oauth-plus/django-oauth-plus-2.2.4.ebuild b/dev-python/django-oauth-plus/django-oauth-plus-2.2.4.ebuild
new file mode 100644
index 000000000000..5354411702f2
--- /dev/null
+++ b/dev-python/django-oauth-plus/django-oauth-plus-2.2.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-oauth-plus/django-oauth-plus-2.2.4.ebuild,v 1.1 2014/01/27 02:24:42 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Support of OAuth 1.0a in Django using python-oauth2"
+HOMEPAGE="http://pypi.python.org/pypi/django-oauth-plus http://code.welldev.org/django-oauth-plus/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/django-1.3[${PYTHON_USEDEP}]
+ >=dev-python/oauth2-1.5.170[${PYTHON_USEDEP}]
+ >=dev-python/south-0.7.5[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_hg[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
+
+python_test() {
+ PYTHONPATH=.:oauth_provider
+ if "${PYTHON}" oauth_provider/runtests/runtests.py; then
+ einfo "Testsuite passed under ${EPYTHON}"
+ else
+ die "Testsuite failed under ${EPYTHON}"
+ fi
+}