summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-02-15 12:12:11 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-02-15 12:12:11 +0000
commit55de5cb11f3beb98e8cb4bdcfb8fef3f583a242e (patch)
tree9534d21abe29258053d2bdec3b1fe533ebc309db /dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild
parentamd64/x86 stable, bug #258579 (diff)
downloadgentoo-2-55de5cb11f3beb98e8cb4bdcfb8fef3f583a242e.tar.gz
gentoo-2-55de5cb11f3beb98e8cb4bdcfb8fef3f583a242e.tar.bz2
gentoo-2-55de5cb11f3beb98e8cb4bdcfb8fef3f583a242e.zip
Fixing dbus dep of 0.83 to fix #258967
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild')
-rw-r--r--dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild b/dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild
new file mode 100644
index 000000000000..2bf6e6ae4d7d
--- /dev/null
+++ b/dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild,v 1.1 2009/02/15 12:12:11 patrick Exp $
+
+inherit python multilib
+
+DESCRIPTION="Python bindings for the D-Bus messagebus."
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/DBusBindings \
+http://dbus.freedesktop.org/doc/dbus-python/"
+SRC_URI="http://dbus.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="test"
+
+RDEPEND=">=dev-lang/python-2.4.4-r5
+ >=dev-python/pyrex-0.9.3-r2
+ >=dev-libs/dbus-glib-0.71
+ >=sys-apps/dbus-1.1.1"
+
+DEPEND="${RDEPEND}
+ test? ( dev-python/pygobject )
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # disable pyc compiling
+ mv "${S}"/py-compile "${S}"/py-compile.orig
+ ln -s $(type -P true) "${S}"/py-compile
+}
+
+src_compile() {
+ econf --docdir=/usr/share/doc/dbus-python-${PV}
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+}
+
+pkg_postinst() {
+ python_version
+ python_need_rebuild
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/dbus
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}