summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-09-12 22:12:34 +0000
committerMichał Górny <mgorny@gentoo.org>2013-09-12 22:12:34 +0000
commitb95b24f704a0ff815022da7548a8004c0ee5e864 (patch)
tree711acdf06551aad91dad83465dfa8e4d5f794226 /dev-python/cmd2
parentno more pyparsing deps, less direct depends and corrected test deps (diff)
downloadgentoo-2-b95b24f704a0ff815022da7548a8004c0ee5e864.tar.gz
gentoo-2-b95b24f704a0ff815022da7548a8004c0ee5e864.tar.bz2
gentoo-2-b95b24f704a0ff815022da7548a8004c0ee5e864.zip
Fix the dependencies and supported implementations. Enable tests. Update HOMEPAGE. Also, bump to the new version that supports py3.
(Portage version: 2.2.3/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-python/cmd2')
-rw-r--r--dev-python/cmd2/ChangeLog11
-rw-r--r--dev-python/cmd2/cmd2-0.6.4-r1.ebuild25
-rw-r--r--dev-python/cmd2/cmd2-0.6.4.ebuild20
-rw-r--r--dev-python/cmd2/cmd2-0.6.6.1.ebuild34
4 files changed, 68 insertions, 22 deletions
diff --git a/dev-python/cmd2/ChangeLog b/dev-python/cmd2/ChangeLog
index b4fc83163e57..3f505aebc127 100644
--- a/dev-python/cmd2/ChangeLog
+++ b/dev-python/cmd2/ChangeLog
@@ -1,10 +1,17 @@
# ChangeLog for dev-python/cmd2
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cmd2/ChangeLog,v 1.1 2013/01/26 08:01:43 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cmd2/ChangeLog,v 1.2 2013/09/12 22:12:34 mgorny Exp $
+
+*cmd2-0.6.4-r1 (12 Sep 2013)
+*cmd2-0.6.6.1 (12 Sep 2013)
+
+ 12 Sep 2013; Michał Górny <mgorny@gentoo.org> +cmd2-0.6.4-r1.ebuild,
+ +cmd2-0.6.6.1.ebuild, -cmd2-0.6.4.ebuild:
+ Fix the dependencies and supported implementations. Enable tests. Update
+ HOMEPAGE. Also, bump to the new version that supports py3.
*cmd2-0.6.4 (26 Jan 2013)
26 Jan 2013; Matthew Thode <prometheanfire@gentoo.org> +cmd2-0.6.4.ebuild,
+metadata.xml:
initial add of cmd2 for cliff for python-quantumclient
-
diff --git a/dev-python/cmd2/cmd2-0.6.4-r1.ebuild b/dev-python/cmd2/cmd2-0.6.4-r1.ebuild
new file mode 100644
index 000000000000..97f8635da9f4
--- /dev/null
+++ b/dev-python/cmd2/cmd2-0.6.4-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cmd2/cmd2-0.6.4-r1.ebuild,v 1.1 2013/09/12 22:12:33 mgorny Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="Extra features for standard library's cmd module"
+HOMEPAGE="https://bitbucket.org/catherinedevlin/cmd2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/pyparsing[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" -m cmd2 -v || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/cmd2/cmd2-0.6.4.ebuild b/dev-python/cmd2/cmd2-0.6.4.ebuild
deleted file mode 100644
index 165900d4de7c..000000000000
--- a/dev-python/cmd2/cmd2-0.6.4.ebuild
+++ /dev/null
@@ -1,20 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cmd2/cmd2-0.6.4.ebuild,v 1.1 2013/01/26 08:01:43 prometheanfire Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 python3_2 )
-
-inherit distutils-r1
-
-DESCRIPTION="Extra features for standard library's cmd module"
-HOMEPAGE="http://packages.python.org/cmd2/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND=""
diff --git a/dev-python/cmd2/cmd2-0.6.6.1.ebuild b/dev-python/cmd2/cmd2-0.6.6.1.ebuild
new file mode 100644
index 000000000000..47b2617ec236
--- /dev/null
+++ b/dev-python/cmd2/cmd2-0.6.6.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cmd2/cmd2-0.6.6.1.ebuild,v 1.1 2013/09/12 22:12:33 mgorny Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="Extra features for standard library's cmd module"
+HOMEPAGE="https://bitbucket.org/catherinedevlin/cmd2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/pyparsing[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # Remove broken pyparsing dep.
+ # https://bitbucket.org/catherinedevlin/cmd2/pull-request/3
+ sed -i -e '/= install_requires/d' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ "${PYTHON}" -m cmd2 -v || die "Tests fail with ${EPYTHON}"
+}