summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-20 01:46:56 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-20 01:46:56 +0000
commit052f79b8a016bd16b62f0b788417c079df979b2d (patch)
tree1f80dd144109846e0db8655aeef7533f981fb02d /dev-python/cheetah
parentDelete older ebuild. (diff)
downloadgentoo-2-052f79b8a016bd16b62f0b788417c079df979b2d.tar.gz
gentoo-2-052f79b8a016bd16b62f0b788417c079df979b2d.tar.bz2
gentoo-2-052f79b8a016bd16b62f0b788417c079df979b2d.zip
Version bump.
(Portage version: 15121-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/cheetah')
-rw-r--r--dev-python/cheetah/ChangeLog8
-rw-r--r--dev-python/cheetah/cheetah-2.4.1.ebuild50
2 files changed, 57 insertions, 1 deletions
diff --git a/dev-python/cheetah/ChangeLog b/dev-python/cheetah/ChangeLog
index 0255a0167c48..0268be00fe2b 100644
--- a/dev-python/cheetah/ChangeLog
+++ b/dev-python/cheetah/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/cheetah
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cheetah/ChangeLog,v 1.58 2009/12/15 16:29:26 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cheetah/ChangeLog,v 1.59 2009/12/20 01:46:56 arfrever Exp $
+
+*cheetah-2.4.1 (20 Dec 2009)
+
+ 20 Dec 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +cheetah-2.4.1.ebuild:
+ Version bump.
15 Dec 2009; Raúl Porcel <armin76@gentoo.org> cheetah-2.4.0.ebuild:
alpha/ia64/sparc stable wrt #294829
diff --git a/dev-python/cheetah/cheetah-2.4.1.ebuild b/dev-python/cheetah/cheetah-2.4.1.ebuild
new file mode 100644
index 000000000000..96ff0b8a2da0
--- /dev/null
+++ b/dev-python/cheetah/cheetah-2.4.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cheetah/cheetah-2.4.1.ebuild,v 1.1 2009/12/20 01:46:56 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_PN="Cheetah"
+MY_P="${MY_PN}-${PV/_}"
+
+DESCRIPTION="Python-powered template engine and code generator."
+HOMEPAGE="http://www.cheetahtemplate.org/ http://rtyler.github.com/cheetah/ http://pypi.python.org/pypi/Cheetah"
+SRC_URI="http://pypi.python.org/packages/source/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="PSF-2.2"
+IUSE=""
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+SLOT="0"
+
+RDEPEND="dev-python/markdown"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="Cheetah"
+DOCS="CHANGES README.markdown TODO"
+
+src_test() {
+ # Disable broken tests.
+ sed \
+ -e "/Unicode/d" \
+ -e "s/if not sys.platform.startswith('java'):/if False:/" \
+ -e "/results =/a\\ sys.exit(not results.wasSuccessful())" \
+ -i cheetah/Tests/Test.py || die "sed failed"
+
+ testing() {
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" cheetah/Tests/Test.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ [[ -z "${ED}" ]] && local ED="${D}"
+ distutils_src_install
+ rm -fr "${ED}"usr/lib*/python*/site-packages/Cheetah/Tests
+}