summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2011-07-30 00:26:24 +0000
committerRafael Martins <rafaelmartins@gentoo.org>2011-07-30 00:26:24 +0000
commit81470a019bb65b5c4576be10b257ca53ea68cc6e (patch)
tree081c46caab9288c5bd536f220622c97ac730763e /dev-python/chameleon
parentInitial version. Thanks to Jan Matějka (bug #361629). (diff)
downloadgentoo-2-81470a019bb65b5c4576be10b257ca53ea68cc6e.tar.gz
gentoo-2-81470a019bb65b5c4576be10b257ca53ea68cc6e.tar.bz2
gentoo-2-81470a019bb65b5c4576be10b257ca53ea68cc6e.zip
Improved test handling. Removed tests dependencies, they are just needed for benchmarks, that we don't support for now.
(Portage version: 2.2.0_alpha46/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/chameleon')
-rw-r--r--dev-python/chameleon/ChangeLog9
-rw-r--r--dev-python/chameleon/chameleon-2.2-r1.ebuild (renamed from dev-python/chameleon/chameleon-2.2.ebuild)23
2 files changed, 14 insertions, 18 deletions
diff --git a/dev-python/chameleon/ChangeLog b/dev-python/chameleon/ChangeLog
index 49363e2438bb..c0c685b2f48e 100644
--- a/dev-python/chameleon/ChangeLog
+++ b/dev-python/chameleon/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/chameleon
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/chameleon/ChangeLog,v 1.1 2011/07/29 23:59:01 rafaelmartins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/chameleon/ChangeLog,v 1.2 2011/07/30 00:26:24 rafaelmartins Exp $
+
+*chameleon-2.2-r1 (30 Jul 2011)
+
+ 30 Jul 2011; Rafael G. Martins <rafaelmartins@gentoo.org>
+ -chameleon-2.2.ebuild, +chameleon-2.2-r1.ebuild:
+ Improved test handling. Removed tests dependencies, they are just needed for
+ benchmarks, that we don't support for now.
*chameleon-2.2 (29 Jul 2011)
diff --git a/dev-python/chameleon/chameleon-2.2.ebuild b/dev-python/chameleon/chameleon-2.2-r1.ebuild
index e8c2b7f25c80..66921b5e514f 100644
--- a/dev-python/chameleon/chameleon-2.2.ebuild
+++ b/dev-python/chameleon/chameleon-2.2-r1.ebuild
@@ -1,13 +1,15 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/chameleon/chameleon-2.2.ebuild,v 1.1 2011/07/29 23:59:01 rafaelmartins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/chameleon/chameleon-2.2-r1.ebuild,v 1.1 2011/07/30 00:26:24 rafaelmartins Exp $
EAPI=3
SUPPORT_PYTHON_ABIS=1
PYTHON_DEPEND="2:2.7 3"
+RESTRICT_PYTHON_ABIS="2.[456]"
+DISTUTILS_SRC_TEST="setup.py"
-inherit distutils python
+inherit distutils
MY_PN="Chameleon"
MY_P="${MY_PN}-${PV}"
@@ -19,19 +21,13 @@ SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
LICENSE="repoze"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
+IUSE="doc"
-DEPEND="doc? ( dev-python/sphinx )
- test? ( net-zope/zope-pagetemplate
- net-zope/zope-component
- net-zope/zope-i18n
- net-zope/zope-testing )"
+DEPEND="doc? ( dev-python/sphinx )"
RDEPEND=""
S="${WORKDIR}/${MY_P}"
-RESTRICT_PYTHON_ABIS="2.[456]"
-
src_compile() {
distutils_src_compile
@@ -40,13 +36,6 @@ src_compile() {
fi
}
-src_test() {
- testing() {
- PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" setup.py "test"
- }
- python_execute_function testing
-}
-
src_install() {
distutils_src_install