summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-06-15 17:38:41 +0000
committerJustin Lecher <jlec@gentoo.org>2015-06-15 17:38:41 +0000
commitb15816fa1eb796d920bfc8fe88fb1858bf61ac92 (patch)
tree98bfa618b86eb596b7dc6fb47e53cb7e61c7df5f /dev-python/cffi
parentUpdating remote-id in metadata.xml (diff)
downloadgentoo-2-b15816fa1eb796d920bfc8fe88fb1858bf61ac92.tar.gz
gentoo-2-b15816fa1eb796d920bfc8fe88fb1858bf61ac92.tar.bz2
gentoo-2-b15816fa1eb796d920bfc8fe88fb1858bf61ac92.zip
Version Bump
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
Diffstat (limited to 'dev-python/cffi')
-rw-r--r--dev-python/cffi/ChangeLog7
-rw-r--r--dev-python/cffi/cffi-1.1.2.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-python/cffi/ChangeLog b/dev-python/cffi/ChangeLog
index 4a69023f15df..92b1b6e81cce 100644
--- a/dev-python/cffi/ChangeLog
+++ b/dev-python/cffi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/cffi
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/ChangeLog,v 1.65 2015/06/02 08:23:14 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/ChangeLog,v 1.66 2015/06/15 17:38:41 jlec Exp $
+
+*cffi-1.1.2 (15 Jun 2015)
+
+ 15 Jun 2015; Justin Lecher <jlec@gentoo.org> +cffi-1.1.2.ebuild:
+ Version Bump
02 Jun 2015; Justin Lecher <jlec@gentoo.org>
+files/cffi-1.1.0-test-backport.patch, cffi-1.1.0.ebuild:
diff --git a/dev-python/cffi/cffi-1.1.2.ebuild b/dev-python/cffi/cffi-1.1.2.ebuild
new file mode 100644
index 000000000000..f8983cc8f48e
--- /dev/null
+++ b/dev-python/cffi/cffi-1.1.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/cffi-1.1.2.ebuild,v 1.1 2015/06/15 17:38:41 jlec Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Foreign Function Interface for Python calling C code"
+HOMEPAGE="http://cffi.readthedocs.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="doc"
+
+RDEPEND="
+ virtual/libffi
+ dev-python/pycparser[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+# Avoid race on _configtest.c (distutils/command/config.py:_gen_temp_sourcefile)
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ py.test -x -v --ignore testing/test_zintegration.py c/ testing/ || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ distutils-r1_python_install_all
+}