summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-05-08 16:02:21 +0000
committerIan Delaney <idella4@gentoo.org>2013-05-08 16:02:21 +0000
commit153ddb2eaf28e7f57822ffd54b4f55a926edee7c (patch)
treeba22fbe5803cf713d6a2a87b2db2dec22be991f4 /dev-python/cffi
parentAdd py3.3 support (diff)
downloadgentoo-2-153ddb2eaf28e7f57822ffd54b4f55a926edee7c.tar.gz
gentoo-2-153ddb2eaf28e7f57822ffd54b4f55a926edee7c.tar.bz2
gentoo-2-153ddb2eaf28e7f57822ffd54b4f55a926edee7c.zip
tidyup in dep list of 0.5-r1, Add py3 support in 0.6, drop pypy2-0 in both consequent to cffi bundled in pypy2.0-beta2, fixes Bug 468804
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/cffi')
-rw-r--r--dev-python/cffi/ChangeLog7
-rw-r--r--dev-python/cffi/cffi-0.5-r1.ebuild6
-rw-r--r--dev-python/cffi/cffi-0.6.ebuild6
3 files changed, 12 insertions, 7 deletions
diff --git a/dev-python/cffi/ChangeLog b/dev-python/cffi/ChangeLog
index 9289a82ef607..925ec4019bcc 100644
--- a/dev-python/cffi/ChangeLog
+++ b/dev-python/cffi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/cffi
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/ChangeLog,v 1.7 2013/04/16 06:14:32 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/ChangeLog,v 1.8 2013/05/08 16:02:21 idella4 Exp $
+
+ 08 May 2013; Ian Delaney <idella4@gentoo.org> cffi-0.5-r1.ebuild,
+ cffi-0.6.ebuild:
+ tidyup in dep list of 0.5-r1, Add py3 support in 0.6, drop pypy2-0 in both
+ consequent to cffi bundled in pypy2.0-beta2, fixes Bug 468804
*cffi-0.6 (16 Apr 2013)
diff --git a/dev-python/cffi/cffi-0.5-r1.ebuild b/dev-python/cffi/cffi-0.5-r1.ebuild
index e2cd0ea35468..90f24594627b 100644
--- a/dev-python/cffi/cffi-0.5-r1.ebuild
+++ b/dev-python/cffi/cffi-0.5-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/cffi-0.5-r1.ebuild,v 1.1 2013/03/20 08:23:58 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/cffi-0.5-r1.ebuild,v 1.2 2013/05/08 16:02:21 idella4 Exp $
EAPI="5"
-PYTHON_COMPAT=( python{2_6,2_7} pypy{1_9,2_0} )
+PYTHON_COMPAT=( python{2_6,2_7} pypy1_9 )
inherit distutils-r1
@@ -17,7 +17,7 @@ KEYWORDS="~amd64 ~x86"
IUSE="doc test"
RDEPEND="virtual/libffi
- dev-python/pycparser[$(python_gen_usedep python{2_6,2_7} pypy{1_9,2_0})]
+ dev-python/pycparser[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/hgdistver"
DEPEND="$REDEPEND
diff --git a/dev-python/cffi/cffi-0.6.ebuild b/dev-python/cffi/cffi-0.6.ebuild
index 78cf618f4372..e1f9585f71fe 100644
--- a/dev-python/cffi/cffi-0.6.ebuild
+++ b/dev-python/cffi/cffi-0.6.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/cffi-0.6.ebuild,v 1.1 2013/04/16 06:14:32 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/cffi-0.6.ebuild,v 1.2 2013/05/08 16:02:21 idella4 Exp $
EAPI="5"
-PYTHON_COMPAT=( python{2_6,2_7} pypy{1_9,2_0} )
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} pypy1_9 )
inherit distutils-r1
@@ -17,7 +17,7 @@ KEYWORDS="~amd64 ~x86"
IUSE="doc test"
RDEPEND="virtual/libffi
- dev-python/pycparser[$(python_gen_usedep python{2_6,2_7} pypy{1_9,2_0})]
+ dev-python/pycparser[$(python_gen_usedep python{2_6,2_7,3_2,3_3} pypy1_9)]
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/hgdistver"
DEPEND="$REDEPEND