summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2014-03-10 08:42:29 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2014-03-10 08:42:29 +0000
commite6a1e47c9ec82e00d44412f2fed722efb4f3dfa9 (patch)
tree937756ff475ffbbdc1c244a0fb801556ff0455ab /dev-python/bottle
parentversion bump fix #503548 (diff)
downloadgentoo-2-e6a1e47c9ec82e00d44412f2fed722efb4f3dfa9.tar.gz
gentoo-2-e6a1e47c9ec82e00d44412f2fed722efb4f3dfa9.tar.bz2
gentoo-2-e6a1e47c9ec82e00d44412f2fed722efb4f3dfa9.zip
version bump fix #503340
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key B658FA13)
Diffstat (limited to 'dev-python/bottle')
-rw-r--r--dev-python/bottle/ChangeLog7
-rw-r--r--dev-python/bottle/bottle-0.12.5.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-python/bottle/ChangeLog b/dev-python/bottle/ChangeLog
index c6ddc013a4bf..118a59fd2f35 100644
--- a/dev-python/bottle/ChangeLog
+++ b/dev-python/bottle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/bottle
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bottle/ChangeLog,v 1.20 2014/01/05 17:51:50 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bottle/ChangeLog,v 1.21 2014/03/10 08:42:29 ultrabug Exp $
+
+*bottle-0.12.5 (10 Mar 2014)
+
+ 10 Mar 2014; Ultrabug <ultrabug@gentoo.org> +bottle-0.12.5.ebuild:
+ version bump fix #503340 thx to Ondřej Súkup
05 Jan 2014; Agostino Sarubbo <ago@gentoo.org> bottle-0.11.6-r1.ebuild:
Stable for sparc, wrt bug #481896
diff --git a/dev-python/bottle/bottle-0.12.5.ebuild b/dev-python/bottle/bottle-0.12.5.ebuild
new file mode 100644
index 000000000000..1b30cc68d906
--- /dev/null
+++ b/dev-python/bottle/bottle-0.12.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bottle/bottle-0.12.5.ebuild,v 1.1 2014/03/10 08:42:29 ultrabug Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0)
+inherit distutils-r1
+
+DESCRIPTION="A fast and simple micro-framework for small web-applications"
+HOMEPAGE="http://pypi.python.org/pypi/bottle http://bottlepy.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+python_prepare_all() {
+ sed -i -e '/scripts/d' setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+pkg_postinst() {
+ elog "Due to problems with bottle.py being in /usr/bin (see bug #474874)"
+ elog "we do as most other distros and do not install the script anymore."
+ elog "If you do want/have to call it directly rather than through your app,"
+ elog "please use the following instead:"
+ elog ' `python -m bottle`'
+}