summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-05-01 08:00:05 +0000
committerTim Harder <radhermit@gentoo.org>2013-05-01 08:00:05 +0000
commitd2b25fb7dd07dc0a0da2ec07345eb3501e5403dc (patch)
tree3229978eec5abdc6c4b2b7e8eb5fd526231b827f /dev-python/boto
parentFix deprecated AM_CONFIG_HEADER in automake 1.13 (bug #467752) (diff)
downloadgentoo-2-d2b25fb7dd07dc0a0da2ec07345eb3501e5403dc.tar.gz
gentoo-2-d2b25fb7dd07dc0a0da2ec07345eb3501e5403dc.tar.bz2
gentoo-2-d2b25fb7dd07dc0a0da2ec07345eb3501e5403dc.zip
Version bump.
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/boto')
-rw-r--r--dev-python/boto/ChangeLog7
-rw-r--r--dev-python/boto/boto-2.9.2.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-python/boto/ChangeLog b/dev-python/boto/ChangeLog
index 19d3e4ff4eb8..e598c7548035 100644
--- a/dev-python/boto/ChangeLog
+++ b/dev-python/boto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/boto
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/ChangeLog,v 1.57 2013/02/20 06:18:44 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/ChangeLog,v 1.58 2013/05/01 08:00:05 radhermit Exp $
+
+*boto-2.9.2 (01 May 2013)
+
+ 01 May 2013; Tim Harder <radhermit@gentoo.org> +boto-2.9.2.ebuild:
+ Version bump.
20 Feb 2013; Matthew Thode <prometheanfire@gentoo.org> boto-2.1.1.ebuild:
added comment to boto-2.1.1 to hopefully prevent bad pruning
diff --git a/dev-python/boto/boto-2.9.2.ebuild b/dev-python/boto/boto-2.9.2.ebuild
new file mode 100644
index 000000000000..6e682ad81e1e
--- /dev/null
+++ b/dev-python/boto/boto-2.9.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/boto-2.9.2.ebuild,v 1.1 2013/05/01 08:00:05 radhermit Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Amazon Web Services API"
+HOMEPAGE="https://github.com/boto/boto http://pypi.python.org/pypi/boto"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/m2crypto )"
+RDEPEND="dev-python/m2crypto"
+
+# requires Amazon Web Services keys to pass some tests
+RESTRICT="test"
+
+python_test() {
+ esetup.py test
+}