summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-05-08 21:56:21 +0000
committerMichał Górny <mgorny@gentoo.org>2014-05-08 21:56:21 +0000
commita6ff798672cb007615ef1a11db56d9bf53530b90 (patch)
treef8c840a529c1cf89750b63e722509d29c8e4ab35 /dev-python/bcrypt/bcrypt-1.0.2-r1.ebuild
parentVersion bump, drop old (diff)
downloadgentoo-2-a6ff798672cb007615ef1a11db56d9bf53530b90.tar.gz
gentoo-2-a6ff798672cb007615ef1a11db56d9bf53530b90.tar.bz2
gentoo-2-a6ff798672cb007615ef1a11db56d9bf53530b90.zip
Add a slot operator on dev-python/cffi dep (bug #506552), and make it conditional to CPython implementations (PyPy has built-in cffi).
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-python/bcrypt/bcrypt-1.0.2-r1.ebuild')
-rw-r--r--dev-python/bcrypt/bcrypt-1.0.2-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/bcrypt/bcrypt-1.0.2-r1.ebuild b/dev-python/bcrypt/bcrypt-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..71c9d4057d86
--- /dev/null
+++ b/dev-python/bcrypt/bcrypt-1.0.2-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bcrypt/bcrypt-1.0.2-r1.ebuild,v 1.1 2014/05/08 21:56:21 mgorny Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Modern password hashing for software and servers"
+HOMEPAGE="https://github.com/dstufft/bcrypt/"
+SRC_URI="https://github.com/pyca/bcrypt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+RDEPEND="$(python_gen_cond_dep '>=dev-python/cffi-0.8:=[${PYTHON_USEDEP}]' python*)
+ !dev-python/py-bcrypt"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ esetup.py test
+}