summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-03-11 06:20:27 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-03-11 06:20:27 +0000
commit4cdd1e8fdbd8a019c83ef27cc7fc3a716eeb9b7d (patch)
tree508ddb86df9fbbeed84c3c3ccede3e123aa28619 /dev-python/autopep8
parentBump (diff)
downloadgentoo-2-4cdd1e8fdbd8a019c83ef27cc7fc3a716eeb9b7d.tar.gz
gentoo-2-4cdd1e8fdbd8a019c83ef27cc7fc3a716eeb9b7d.tar.bz2
gentoo-2-4cdd1e8fdbd8a019c83ef27cc7fc3a716eeb9b7d.zip
Bump
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/autopep8')
-rw-r--r--dev-python/autopep8/ChangeLog7
-rw-r--r--dev-python/autopep8/autopep8-0.8.7.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-python/autopep8/ChangeLog b/dev-python/autopep8/ChangeLog
index e9462c17305d..a37f19c3d401 100644
--- a/dev-python/autopep8/ChangeLog
+++ b/dev-python/autopep8/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/autopep8
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/autopep8/ChangeLog,v 1.28 2013/01/28 18:45:33 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/autopep8/ChangeLog,v 1.29 2013/03/11 06:20:27 patrick Exp $
+
+*autopep8-0.8.7 (11 Mar 2013)
+
+ 11 Mar 2013; Patrick Lauer <patrick@gentoo.org> +autopep8-0.8.7.ebuild:
+ Bump
28 Jan 2013; Kacper Kowalik <xarthisius@gentoo.org> autopep8-0.8.6-r1.ebuild:
Drop redundant PYTHONPATH in python_test, thanks to mgorny for hint
diff --git a/dev-python/autopep8/autopep8-0.8.7.ebuild b/dev-python/autopep8/autopep8-0.8.7.ebuild
new file mode 100644
index 000000000000..1a2f7a5f056c
--- /dev/null
+++ b/dev-python/autopep8/autopep8-0.8.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/autopep8/autopep8-0.8.7.ebuild,v 1.1 2013/03/11 06:20:27 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="https://github.com/hhatto/autopep8 http://pypi.python.org/pypi/autopep8"
+SRC_URI="https://github.com/hhatto/${PN}/tarball/ver${PV} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=dev-python/pep8-1.3.2
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ "${PYTHON}" setup.py test || die
+}
+
+pkg_postinst() {
+ ewarn "Since this version of autopep depends on >=dev-python/pep8-1.3"
+ ewarn "it is affected by https://github.com/jcrocholl/pep8/issues/45"
+ ewarn "(indentation checks inside triple-quotes)."
+ ewarn "If you do not want to be affected by this, then add the"
+ ewarn "following lines to your local package.mask:"
+ ewarn " >=dev-python/pep8-1.3"
+ ewarn " >=dev-python/autopep8-0.6"
+}