summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-12-05 01:48:18 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-12-05 01:48:18 +0000
commit8a87ed9e70bbb729344ce312a880c544e9c0780a (patch)
tree7b75e32f80e57363ae9ea5afb8c76a94acbb75c4 /dev-python/asciitable
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-8a87ed9e70bbb729344ce312a880c544e9c0780a.tar.gz
gentoo-2-8a87ed9e70bbb729344ce312a880c544e9c0780a.tar.bz2
gentoo-2-8a87ed9e70bbb729344ce312a880c544e9c0780a.zip
Version bump
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/asciitable')
-rw-r--r--dev-python/asciitable/ChangeLog8
-rw-r--r--dev-python/asciitable/asciitable-0.4.0.ebuild (renamed from dev-python/asciitable/asciitable-0.2.6.ebuild)20
2 files changed, 20 insertions, 8 deletions
diff --git a/dev-python/asciitable/ChangeLog b/dev-python/asciitable/ChangeLog
index 385b22648576..b9c25ddb2678 100644
--- a/dev-python/asciitable/ChangeLog
+++ b/dev-python/asciitable/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/asciitable
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/asciitable/ChangeLog,v 1.4 2010/09/29 21:17:21 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/asciitable/ChangeLog,v 1.5 2010/12/05 01:48:18 bicatali Exp $
+
+*asciitable-0.4.0 (05 Dec 2010)
+
+ 05 Dec 2010; Sébastien Fabbro <bicatali@gentoo.org>
+ -asciitable-0.2.6.ebuild, +asciitable-0.4.0.ebuild:
+ Version bump
29 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
asciitable-0.3.1.ebuild:
diff --git a/dev-python/asciitable/asciitable-0.2.6.ebuild b/dev-python/asciitable/asciitable-0.4.0.ebuild
index 8d9eb6515c06..6f7e8d84b75e 100644
--- a/dev-python/asciitable/asciitable-0.2.6.ebuild
+++ b/dev-python/asciitable/asciitable-0.4.0.ebuild
@@ -1,12 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/asciitable/asciitable-0.2.6.ebuild,v 1.2 2010/09/10 21:36:20 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/asciitable/asciitable-0.4.0.ebuild,v 1.1 2010/12/05 01:48:18 bicatali Exp $
EAPI="3"
-PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-DISTUTILS_SRC_TEST="nosetests"
inherit distutils
@@ -17,9 +14,18 @@ SRC_URI="${HOMEPAGE}/downloads/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="test"
-DEPEND="dev-python/numpy"
-RDEPEND="${DEPEND}"
+RDEPEND="dev-python/numpy"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose )"
PYTHON_MODNAME="asciitable.py"
+
+src_test() {
+ testing() {
+ [[ "${PYTHON_ABI}" == 3.* ]] && return
+ PYTHONPATH="build-${PYTHON_ABI}/lib" nosetests
+ }
+ python_execute_function testing
+}