summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-10-12 23:09:43 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-10-12 23:09:43 +0000
commit2c62716c2544497e23a6362c1ca755d5ca562504 (patch)
tree9f6ef16ce032e02988b02a9efb1e1d34997df416 /dev-python/aplpy/aplpy-0.9.5.ebuild
parentInitial import to the main tree (diff)
downloadgentoo-2-2c62716c2544497e23a6362c1ca755d5ca562504.tar.gz
gentoo-2-2c62716c2544497e23a6362c1ca755d5ca562504.tar.bz2
gentoo-2-2c62716c2544497e23a6362c1ca755d5ca562504.zip
Initial import to the main tree
(Portage version: 2.2_rc91/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/aplpy/aplpy-0.9.5.ebuild')
-rw-r--r--dev-python/aplpy/aplpy-0.9.5.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/aplpy/aplpy-0.9.5.ebuild b/dev-python/aplpy/aplpy-0.9.5.ebuild
new file mode 100644
index 000000000000..0b16e73e0afd
--- /dev/null
+++ b/dev-python/aplpy/aplpy-0.9.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/aplpy/aplpy-0.9.5.ebuild,v 1.1 2010/10/12 23:09:43 bicatali Exp $
+
+EAPI=2
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MYP="APLpy-${PV}"
+
+DESCRIPTION="Astronomical Plotting Library in Python"
+HOMEPAGE="http://aplpy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MYP}.tar.gz"
+
+IUSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-3"
+
+DEPEND="dev-python/numpy"
+RDEPEND="${DEPEND}
+ dev-python/matplotlib
+ dev-python/pyfits
+ dev-python/pywcs"
+
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MYP}"