summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2002-01-07 23:32:24 +0000
committerBart Verwilst <verwilst@gentoo.org>2002-01-07 23:32:24 +0000
commit3c9eae31b26dc7428a4c288635a8386507ba0f2f (patch)
tree8d7514e344e71612dea8a0ed49d4ff63438e446f /dev-python/anygui
parentMoved wxPython to dev-python, added digest for python 2.2 (diff)
downloadgentoo-2-3c9eae31b26dc7428a4c288635a8386507ba0f2f.tar.gz
gentoo-2-3c9eae31b26dc7428a4c288635a8386507ba0f2f.tar.bz2
gentoo-2-3c9eae31b26dc7428a4c288635a8386507ba0f2f.zip
anygui, cool Gui module for Python
Diffstat (limited to 'dev-python/anygui')
-rw-r--r--dev-python/anygui/anygui-0.1_beta1.ebuild36
-rw-r--r--dev-python/anygui/files/digest-anygui-0.1_beta11
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/anygui/anygui-0.1_beta1.ebuild b/dev-python/anygui/anygui-0.1_beta1.ebuild
new file mode 100644
index 000000000000..694266196b08
--- /dev/null
+++ b/dev-python/anygui/anygui-0.1_beta1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Tod Neidt <tneidt@fidnet.com>
+#$Header $
+
+pv="0.1b1"
+S=${WORKDIR}/${PN}-${pv}
+DESCRIPTION="Generic GUI Module for Python"
+SRC_URI="http://prdownloads.sourceforge.net/anygui/${PN}-${pv}.tar.gz"
+HOMEPAGE="http://anygui.sourceforge.net/"
+
+DEPEND=">=dev-lang/python-2.0
+ sys-libs/ncurses
+ qt? ( dev-python/PyQt )
+ gtk? ( dev-python/pygtk )
+ tcltk? ( dev-lang/tcl-tk-8.3.3 )"
+ #tcltk? ( dev-tcltk/tk-8.3.3 ) if my tcl and tk ebuilds are commited
+#future:
+# might need a wxw use variable for wxGTK for wxw? ( dev-python/wxPython )
+# also use variable fltk for fltk? ( dev-python/PyFLTK ) no ebuild for PyFLTK yet
+# java? ( dev-python/jython ) Java Swing (javagui) http://www.jython.org
+
+src_compile() {
+
+ python setup.py build || die
+
+}
+
+src_install() {
+
+ python setup.py install --prefix=${D}/usr || die
+
+ dodoc CHANGELOG.txt INSTALL.txt KNOWN_BUGS.txt LICENSE.txt \
+ MAINTAINERS.txt PKG-INFO README.txt TODO.txt VERSION.txt
+
+}
diff --git a/dev-python/anygui/files/digest-anygui-0.1_beta1 b/dev-python/anygui/files/digest-anygui-0.1_beta1
new file mode 100644
index 000000000000..5c097a361ec4
--- /dev/null
+++ b/dev-python/anygui/files/digest-anygui-0.1_beta1
@@ -0,0 +1 @@
+MD5 120aad818247265e36e48e4413772bab anygui-0.1b1.tar.gz 716800