summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-09-05 12:59:12 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-09-05 12:59:12 +0000
commit5dd9fca58bf05f2f3eb15667e92cf4f502273956 (patch)
tree2e3b672ddf4e3abbff6c608f3e61419fb1a12155 /dev-python/PyQt
parentoopsie. Accidentally broke pykota dep. Restoring 3.4.2 (diff)
downloadgentoo-2-5dd9fca58bf05f2f3eb15667e92cf4f502273956.tar.gz
gentoo-2-5dd9fca58bf05f2f3eb15667e92cf4f502273956.tar.bz2
gentoo-2-5dd9fca58bf05f2f3eb15667e92cf4f502273956.zip
Remove old
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/PyQt')
-rw-r--r--dev-python/PyQt/ChangeLog6
-rw-r--r--dev-python/PyQt/PyQt-3.18-r1.ebuild60
-rw-r--r--dev-python/PyQt/PyQt-3.18.ebuild58
3 files changed, 5 insertions, 119 deletions
diff --git a/dev-python/PyQt/ChangeLog b/dev-python/PyQt/ChangeLog
index c543c7cd12f2..b77b46c2be03 100644
--- a/dev-python/PyQt/ChangeLog
+++ b/dev-python/PyQt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/PyQt
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/ChangeLog,v 1.120 2009/06/16 17:58:42 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/ChangeLog,v 1.121 2009/09/05 12:59:12 patrick Exp $
+
+ 05 Sep 2009; Patrick Lauer <patrick@gentoo.org> -PyQt-3.18.ebuild,
+ -PyQt-3.18-r1.ebuild:
+ Remove old
16 Jun 2009; Markos Chandras <hwoarang@gentoo.org> PyQt-3.18.1.ebuild:
Raise sip dependency to 4.8.1
diff --git a/dev-python/PyQt/PyQt-3.18-r1.ebuild b/dev-python/PyQt/PyQt-3.18-r1.ebuild
deleted file mode 100644
index e17c89699f3f..000000000000
--- a/dev-python/PyQt/PyQt-3.18-r1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.18-r1.ebuild,v 1.1 2009/06/13 16:23:35 hwoarang Exp $
-
-EAPI="2"
-inherit distutils
-
-MY_P="PyQt-x11-gpl-${PV/*_pre/snapshot-}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="A set of Python bindings for Qt3"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/pyqt/intro/"
-SRC_URI="http://www.riverbankcomputing.com/static/Downloads/PyQt3/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="debug doc examples"
-
-RDEPEND="x11-libs/qt:3
- >=dev-python/sip-4.8
- >=x11-libs/qscintilla-2.4[python]"
-DEPEND="${RDEPEND}
- sys-devel/libtool"
-
-src_prepare() {
- sed -i -e "s: check_license():# check_license():" "${S}"/configure.py
- epatch "${FILESDIR}"/python_2.5_build_fix.patch
-}
-
-src_configure() {
- distutils_python_version
- addpredict ${QTDIR}/etc/settings
-
- local myconf="-d $(python_get_sitedir) \
- -b /usr/bin \
- -v /usr/share/sip \
- -n /usr/include \
- -o /usr/$(get_libdir) \
- -w -y qt-mt
- -u"
- use debug && myconf="${myconf} -u"
-
- "${python}" configure.py ${myconf} || die 'configure failed'
-}
-
-src_compile() {
- emake || die "emake failed"
-}
-
-src_install() {
- python_need_rebuild
- make DESTDIR="${D}" install || die "install failed"
- dodoc ChangeLog NEWS README THANKS
- use doc && dohtml doc/PyQt.html
- if use examples ; then
- dodir /usr/share/doc/${PF}/examples
- cp -r examples3/* "${D}"/usr/share/doc/${PF}/examples
- fi
-}
diff --git a/dev-python/PyQt/PyQt-3.18.ebuild b/dev-python/PyQt/PyQt-3.18.ebuild
deleted file mode 100644
index 4a89ec968174..000000000000
--- a/dev-python/PyQt/PyQt-3.18.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.18.ebuild,v 1.2 2009/06/09 20:12:15 hwoarang Exp $
-
-EAPI="2"
-inherit distutils
-
-MY_P="PyQt-x11-gpl-${PV/*_pre/snapshot-}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="A set of Python bindings for Qt3"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/pyqt/intro/"
-SRC_URI="http://www.riverbankcomputing.com/static/Downloads/PyQt3/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="debug doc examples"
-
-RDEPEND="x11-libs/qt:3
- >=dev-python/sip-4.8
- >=x11-libs/qscintilla-2.4[python]"
-DEPEND="${RDEPEND}
- sys-devel/libtool"
-
-src_prepare() {
- sed -i -e "s: check_license():# check_license():" "${S}"/configure.py
-}
-
-src_configure() {
- distutils_python_version
- addpredict ${QTDIR}/etc/settings
-
- local myconf="-d $(python_get_sitedir) \
- -b /usr/bin \
- -v /usr/share/sip \
- -n /usr/include \
- -o /usr/$(get_libdir) \
- -w -y qt-mt"
- use debug && myconf="${myconf} -u"
-
- "${python}" configure.py ${myconf} || die 'configure failed'
-}
-
-src_compile() {
- emake || die "emake failed"
-}
-
-src_install() {
- python_need_rebuild
- make DESTDIR="${D}" install || die "install failed"
- dodoc ChangeLog NEWS README THANKS
- use doc && dohtml doc/PyQt.html
- if use examples ; then
- dodir /usr/share/doc/${PF}/examples
- cp -r examples3/* "${D}"/usr/share/doc/${PF}/examples
- fi
-}