summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2015-02-25 02:53:10 +0000
committerBrian Evans <grknight@gentoo.org>2015-02-25 02:53:10 +0000
commitc09bed49a8d54093f50e09dec0676e9756799c1d (patch)
treebf146a97c3120de61a00dbed565c150d938156fc /dev-php
parentVersion bump; Update LICENSE to BSD per upstream (diff)
downloadgentoo-2-c09bed49a8d54093f50e09dec0676e9756799c1d.tar.gz
gentoo-2-c09bed49a8d54093f50e09dec0676e9756799c1d.tar.bz2
gentoo-2-c09bed49a8d54093f50e09dec0676e9756799c1d.zip
Version bump
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key 0xD1F781EFF9F4A3B6)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-gnupg/ChangeLog9
-rw-r--r--dev-php/pecl-gnupg/pecl-gnupg-1.3.6.ebuild31
2 files changed, 38 insertions, 2 deletions
diff --git a/dev-php/pecl-gnupg/ChangeLog b/dev-php/pecl-gnupg/ChangeLog
index f2b9fe347ff1..df7bce910bcd 100644
--- a/dev-php/pecl-gnupg/ChangeLog
+++ b/dev-php/pecl-gnupg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/pecl-gnupg
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-gnupg/ChangeLog,v 1.5 2014/10/10 01:49:10 grknight Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-gnupg/ChangeLog,v 1.6 2015/02/25 02:53:10 grknight Exp $
+
+*pecl-gnupg-1.3.6 (25 Feb 2015)
+
+ 25 Feb 2015; Brian Evans <grknight@gentoo.org> +pecl-gnupg-1.3.6.ebuild:
+ Version bump
*pecl-gnupg-1.3.3 (30 Sep 2014)
diff --git a/dev-php/pecl-gnupg/pecl-gnupg-1.3.6.ebuild b/dev-php/pecl-gnupg/pecl-gnupg-1.3.6.ebuild
new file mode 100644
index 000000000000..0929ee3d2140
--- /dev/null
+++ b/dev-php/pecl-gnupg/pecl-gnupg-1.3.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-gnupg/pecl-gnupg-1.3.6.ebuild,v 1.1 2015/02/25 02:53:10 grknight Exp $
+
+EAPI="5"
+
+PHP_EXT_NAME="gnupg"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+USE_PHP="php5-6 php5-5 php5-4"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="~amd64 ~x86"
+DESCRIPTION="PHP wrapper around the gpgme library"
+LICENSE="BSD-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="app-crypt/gpgme"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ for slot in $(php_get_slots); do
+ php_init_slot_env ${slot}
+ epatch "${FILESDIR}"/1.3.2/01-large_file_system.patch
+ done
+
+ php-ext-source-r2_src_prepare
+}