summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2015-04-29 00:59:21 +0000
committerBrian Evans <grknight@gentoo.org>2015-04-29 00:59:21 +0000
commit919a58b4c0b4b8001b4e89cc834b943af539c1e2 (patch)
tree11d81d05f830bbf4b8258d474548ad7bf1cf408e /dev-php
parentAutomated update. (diff)
downloadgentoo-2-919a58b4c0b4b8001b4e89cc834b943af539c1e2.tar.gz
gentoo-2-919a58b4c0b4b8001b4e89cc834b943af539c1e2.tar.bz2
gentoo-2-919a58b4c0b4b8001b4e89cc834b943af539c1e2.zip
Revbump to add php5-6 wrt bug 548038
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xD1F781EFF9F4A3B6)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-haru/ChangeLog9
-rw-r--r--dev-php/pecl-haru/pecl-haru-1.0.4-r1.ebuild28
2 files changed, 35 insertions, 2 deletions
diff --git a/dev-php/pecl-haru/ChangeLog b/dev-php/pecl-haru/ChangeLog
index a678a59ba06b..e7c408152ad5 100644
--- a/dev-php/pecl-haru/ChangeLog
+++ b/dev-php/pecl-haru/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/pecl-haru
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-haru/ChangeLog,v 1.6 2014/10/09 20:51:00 grknight Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-haru/ChangeLog,v 1.7 2015/04/29 00:59:21 grknight Exp $
+
+*pecl-haru-1.0.4-r1 (29 Apr 2015)
+
+ 29 Apr 2015; Brian Evans <grknight@gentoo.org> +pecl-haru-1.0.4-r1.ebuild:
+ Revbump to add php5-6 wrt bug 548038
30 Sep 2014; Brian Evans <grknight@gentoo.org> -pecl-haru-1.0.3.ebuild:
Drop support for php5.3
diff --git a/dev-php/pecl-haru/pecl-haru-1.0.4-r1.ebuild b/dev-php/pecl-haru/pecl-haru-1.0.4-r1.ebuild
new file mode 100644
index 000000000000..7513ad61d538
--- /dev/null
+++ b/dev-php/pecl-haru/pecl-haru-1.0.4-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-haru/pecl-haru-1.0.4-r1.ebuild,v 1.1 2015/04/29 00:59:21 grknight Exp $
+
+EAPI=5
+
+USE_PHP="php5-4 php5-5 php5-6"
+
+inherit php-ext-pecl-r2
+
+DESCRIPTION="An interface to libharu, a PDF generator"
+
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="png zlib"
+
+DEPEND="media-libs/libharu[png?,zlib?]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # config.m4 is broken checking paths, so we need to override it
+ my_conf=""
+ use png && my_conf+=" --with-png-dir=/usr"
+ use zlib && my_conf+=" --with-zlib-dir=/usr"
+
+ php-ext-source-r2_src_configure
+}