summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavoz@gentoo.org>2004-12-17 01:26:40 +0000
committerGustavo Zacarias <gustavoz@gentoo.org>2004-12-17 01:26:40 +0000
commit3814f52a7478f9d0c93988cb7dc65ba314383c79 (patch)
tree4347c0b92b2dba8214b063751803a351542fc0c2 /dev-php
parentStable on sparc (Manifest recommit) (diff)
downloadgentoo-2-3814f52a7478f9d0c93988cb7dc65ba314383c79.tar.gz
gentoo-2-3814f52a7478f9d0c93988cb7dc65ba314383c79.tar.bz2
gentoo-2-3814f52a7478f9d0c93988cb7dc65ba314383c79.zip
Stable on sparc wrt #74547, solves #74627
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/php/ChangeLog6
-rw-r--r--dev-php/php/files/stdint.diff11
-rw-r--r--dev-php/php/php-4.3.10.ebuild5
3 files changed, 19 insertions, 3 deletions
diff --git a/dev-php/php/ChangeLog b/dev-php/php/ChangeLog
index 0647b60f931b..4e30cd26896b 100644
--- a/dev-php/php/ChangeLog
+++ b/dev-php/php/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-php/php
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php/ChangeLog,v 1.135 2004/12/16 10:40:04 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/ChangeLog,v 1.136 2004/12/17 01:26:40 gustavoz Exp $
+
+ 16 Dec 2004; Gustavo Zacarias <gustavoz@gentoo.org> +files/stdint.diff,
+ php-4.3.10.ebuild:
+ Stable on sparc wrt #74547, solves #74627
16 Dec 2004; Dylan Carlson <absinthe@gentoo.org> php-4.3.10.ebuild:
Stable on amd64 for bug 74547.
diff --git a/dev-php/php/files/stdint.diff b/dev-php/php/files/stdint.diff
new file mode 100644
index 000000000000..451d7fb44cf3
--- /dev/null
+++ b/dev-php/php/files/stdint.diff
@@ -0,0 +1,11 @@
+diff -Nura php-4.3.10/Zend/zend_strtod.c php-4.3.10.stdint/Zend/zend_strtod.c
+--- php-4.3.10/Zend/zend_strtod.c 2004-12-14 05:35:26.000000000 -0300
++++ php-4.3.10.stdint/Zend/zend_strtod.c 2004-12-16 15:33:47.000000000 -0300
+@@ -128,6 +128,7 @@
+ #endif
+
+ #if defined(__sparc__) || defined(__ppc__)
++#include <stdint.h>
+ #define u_int32_t uint32_t
+ #endif
+
diff --git a/dev-php/php/php-4.3.10.ebuild b/dev-php/php/php-4.3.10.ebuild
index 81e41e7bac34..b8db6f72a6e3 100644
--- a/dev-php/php/php-4.3.10.ebuild
+++ b/dev-php/php/php-4.3.10.ebuild
@@ -1,18 +1,19 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-4.3.10.ebuild,v 1.4 2004/12/16 10:40:04 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-4.3.10.ebuild,v 1.5 2004/12/17 01:26:40 gustavoz Exp $
PHPSAPI="cli"
inherit php-sapi eutils
DESCRIPTION="PHP Shell Interpreter"
SLOT="0"
-KEYWORDS="x86 ppc ~sparc ~alpha ~hppa amd64 ~ia64 ~s390 ppc64 ~mips"
+KEYWORDS="x86 ppc sparc ~alpha ~hppa amd64 ~ia64 ~s390 ppc64 ~mips"
IUSE=""
src_unpack() {
php-sapi_src_unpack
[ "${ARCH}" == "amd64" ] && epatch ${FILESDIR}/php-4.3.4-amd64hack.diff
+ [ "${ARCH}" == "sparc" ] && epatch ${FILESDIR}/stdint.diff
}
src_compile() {