summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2007-11-29 23:52:21 +0000
committerMarkus Ullmann <jokey@gentoo.org>2007-11-29 23:52:21 +0000
commita3e2afe7a057ea04db0713abbac42585a99def0b (patch)
tree701cf893bcee0c01459019f6fa379741cb822e0d /dev-php5/pecl-pam/pecl-pam-1.0.2.ebuild
parentVersion bump from project overlay (diff)
downloadgentoo-2-a3e2afe7a057ea04db0713abbac42585a99def0b.tar.gz
gentoo-2-a3e2afe7a057ea04db0713abbac42585a99def0b.tar.bz2
gentoo-2-a3e2afe7a057ea04db0713abbac42585a99def0b.zip
Version bump from project overlay
(Portage version: 2.1.4_rc4)
Diffstat (limited to 'dev-php5/pecl-pam/pecl-pam-1.0.2.ebuild')
-rw-r--r--dev-php5/pecl-pam/pecl-pam-1.0.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-php5/pecl-pam/pecl-pam-1.0.2.ebuild b/dev-php5/pecl-pam/pecl-pam-1.0.2.ebuild
new file mode 100644
index 000000000000..b62d52aea1f3
--- /dev/null
+++ b/dev-php5/pecl-pam/pecl-pam-1.0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-pam/pecl-pam-1.0.2.ebuild,v 1.1 2007/11/29 23:52:21 jokey Exp $
+
+PHP_EXT_NAME="pam"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="README"
+
+inherit php-ext-pecl-r1 pam
+
+KEYWORDS="~x86"
+
+DESCRIPTION="This extension provides PAM (Pluggable Authentication Modules) integration."
+LICENSE="PHP"
+SLOT="0"
+IUSE="debug"
+
+DEPEND="sys-libs/pam"
+RDEPEND="${DEPEND}"
+
+need_php_by_category
+
+src_compile() {
+ my_conf="--with-pam=/usr $(use_enable debug)"
+ php-ext-pecl-r1_src_compile
+}
+
+src_install() {
+ pamd_mimic_system php auth account password
+ php-ext-pecl-r1_src_install
+}