summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2007-08-27 10:13:12 +0000
committerMarkus Ullmann <jokey@gentoo.org>2007-08-27 10:13:12 +0000
commite46af7fff1ec3ce21b01f0edc340ccc3357170ae (patch)
treec4ba2670efefe1ab9ba27c6ddcd1b38980e132f3 /dev-php5/pecl-http/pecl-http-1.5.4.ebuild
parentVersion bump. (diff)
downloadgentoo-2-e46af7fff1ec3ce21b01f0edc340ccc3357170ae.tar.gz
gentoo-2-e46af7fff1ec3ce21b01f0edc340ccc3357170ae.tar.bz2
gentoo-2-e46af7fff1ec3ce21b01f0edc340ccc3357170ae.zip
version bump for bug #190381
(Portage version: 2.1.3.6)
Diffstat (limited to 'dev-php5/pecl-http/pecl-http-1.5.4.ebuild')
-rw-r--r--dev-php5/pecl-http/pecl-http-1.5.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-php5/pecl-http/pecl-http-1.5.4.ebuild b/dev-php5/pecl-http/pecl-http-1.5.4.ebuild
new file mode 100644
index 000000000000..266bf01ee418
--- /dev/null
+++ b/dev-php5/pecl-http/pecl-http-1.5.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-http/pecl-http-1.5.4.ebuild,v 1.1 2007/08/27 10:13:12 jokey Exp $
+
+PHP_EXT_NAME="http"
+PHP_EXT_PECL_PKG="pecl_http"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+inherit php-ext-pecl-r1
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Extended HTTP Support for PHP."
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND="net-misc/curl
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+need_php_by_category
+
+src_compile() {
+ my_conf="--enable-http \
+ --with-http-curl-requests \
+ --with-http-zlib-compression"
+
+ php-ext-pecl-r1_src_compile
+}
+
+pkg_postinst() {
+ has_php
+ if ! built_with_use --missing true =${PHP_PKG} spl session hash iconv ; then
+ elog "${PN} can optionally use spl, session, hash and iconv features."
+ elog "If you want those, recompile ${PHP_PKG} with those flags in USE."
+ fi
+}