summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Hoffmann <hoffie@gentoo.org>2008-05-07 19:54:16 +0000
committerChristian Hoffmann <hoffie@gentoo.org>2008-05-07 19:54:16 +0000
commitb02abe67e6fca23f66da4cc266bfaa15db7e2f33 (patch)
tree39fd9928bfa71d42684126521e93976970cee19d /dev-php5/pecl-apc
parentVersion bump wrt bug #218472 (diff)
downloadgentoo-2-b02abe67e6fca23f66da4cc266bfaa15db7e2f33.tar.gz
gentoo-2-b02abe67e6fca23f66da4cc266bfaa15db7e2f33.tar.bz2
gentoo-2-b02abe67e6fca23f66da4cc266bfaa15db7e2f33.zip
update ini settings (thanks to Lars Strojny <lars@strojny.net> for pointing that out in #gentoo-php)
(Portage version: 2.1.5_rc7)
Diffstat (limited to 'dev-php5/pecl-apc')
-rw-r--r--dev-php5/pecl-apc/ChangeLog10
-rw-r--r--dev-php5/pecl-apc/pecl-apc-3.0.18-r1.ebuild76
2 files changed, 85 insertions, 1 deletions
diff --git a/dev-php5/pecl-apc/ChangeLog b/dev-php5/pecl-apc/ChangeLog
index b4e8933427ea..65b4f1eda84c 100644
--- a/dev-php5/pecl-apc/ChangeLog
+++ b/dev-php5/pecl-apc/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-php5/pecl-apc
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-apc/ChangeLog,v 1.45 2008/05/07 16:29:32 hoffie Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-apc/ChangeLog,v 1.46 2008/05/07 19:54:16 hoffie Exp $
+
+*pecl-apc-3.0.18-r1 (07 May 2008)
+
+ 07 May 2008; Christian Hoffmann <hoffie@gentoo.org>
+ +pecl-apc-3.0.18-r1.ebuild:
+ update ini settings (drop optimizer as it is simply ignored, add options
+ which upstream recently added, thanks to Lars Strojny <lars@strojny.net>
+ for pointing that out in #gentoo-php)
07 May 2008; Christian Hoffmann <hoffie@gentoo.org>
pecl-apc-3.0.16.ebuild, pecl-apc-3.0.16-r1.ebuild:
diff --git a/dev-php5/pecl-apc/pecl-apc-3.0.18-r1.ebuild b/dev-php5/pecl-apc/pecl-apc-3.0.18-r1.ebuild
new file mode 100644
index 000000000000..0efbc9a47809
--- /dev/null
+++ b/dev-php5/pecl-apc/pecl-apc-3.0.18-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-apc/pecl-apc-3.0.18-r1.ebuild,v 1.1 2008/05/07 19:54:16 hoffie Exp $
+
+PHP_EXT_NAME="apc"
+PHP_EXT_PECL_PKG="APC"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="CHANGELOG INSTALL NOTICE TECHNOTES.txt TODO"
+
+inherit php-ext-pecl-r1 confutils eutils
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DESCRIPTION="A free, open, and robust framework for caching and optimizing PHP code."
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE="mmap"
+
+DEPEND="!dev-php5/eaccelerator !dev-php5/xcache"
+RDEPEND="${DEPEND}"
+
+need_php_by_category
+
+pkg_setup() {
+ require_php_sapi_from cgi apache2
+}
+
+src_compile() {
+ has_php
+
+ my_conf="--enable-apc"
+ enable_extension_enable "apc-mmap" "mmap" 0
+ enable_extension_with_built_with =${PHP_PKG} apache2 apxs /usr/sbin/apxs2 "optimisation for apache2"
+
+ php-ext-pecl-r1_src_compile
+}
+
+src_install() {
+ php-ext-pecl-r1_src_install
+
+ php-ext-base-r1_addtoinifiles "apc.enabled" '"1"'
+ php-ext-base-r1_addtoinifiles "apc.shm_segments" '"1"'
+ php-ext-base-r1_addtoinifiles "apc.shm_size" '"30"'
+ php-ext-base-r1_addtoinifiles "apc.num_files_hint" '"1024"'
+ php-ext-base-r1_addtoinifiles "apc.ttl" '"7200"'
+ php-ext-base-r1_addtoinifiles "apc.user_ttl" '"7200"'
+ php-ext-base-r1_addtoinifiles "apc.gc_ttl" '"3600"'
+ php-ext-base-r1_addtoinifiles "apc.cache_by_default" '"1"'
+ php-ext-base-r1_addtoinifiles ";apc.filters" '""'
+ php-ext-base-r1_addtoinifiles ";apc.mmap_file_mask" '"/tmp/apcphp5.XXXXXX"'
+ php-ext-base-r1_addtoinifiles "apc.slam_defense" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.file_update_protection" '"2"'
+ php-ext-base-r1_addtoinifiles "apc.enable_cli" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.max_file_size" '"1M"'
+ php-ext-base-r1_addtoinifiles "apc.stat" '"1"'
+ php-ext-base-r1_addtoinifiles "apc.write_lock" '"1"'
+ php-ext-base-r1_addtoinifiles "apc.report_autofilter" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.include_once_override" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.rfc1867" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.rfc1867_prefix" '"upload_"'
+ php-ext-base-r1_addtoinifiles "apc.rfc1867_name" '"APC_UPLOAD_PROGRESS"'
+ php-ext-base-r1_addtoinifiles "apc.rfc1867_freq" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.localcache" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.localcache.size" '"512"'
+ php-ext-base-r1_addtoinifiles "apc.coredump_unmap" '"0"'
+
+ dodir "${PHP_EXT_SHARED_DIR}"
+ insinto "${PHP_EXT_SHARED_DIR}"
+ doins apc.php
+}
+
+pkg_postinst() {
+ elog "The apc.php file shipped with this release of PECL-APC was"
+ elog "installed into ${ROOT}usr/share/php5/apc/."
+}