summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2013-04-14 06:27:09 +0000
committerOle Markus With <olemarkus@gentoo.org>2013-04-14 06:27:09 +0000
commitfe486672d5130e77d2d83ec223c4f96481947610 (patch)
tree8278905675405296e0c36ab11391fe3c9f3ab61c /dev-php/xdebug-client
parentAdd USE=libopts to control deletion of libopts tarball #465370 by Martin von ... (diff)
downloadgentoo-2-fe486672d5130e77d2d83ec223c4f96481947610.tar.gz
gentoo-2-fe486672d5130e77d2d83ec223c4f96481947610.tar.bz2
gentoo-2-fe486672d5130e77d2d83ec223c4f96481947610.zip
Version bump
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key C4A92BF5)
Diffstat (limited to 'dev-php/xdebug-client')
-rw-r--r--dev-php/xdebug-client/ChangeLog8
-rw-r--r--dev-php/xdebug-client/xdebug-client-2.2.2.ebuild30
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-php/xdebug-client/ChangeLog b/dev-php/xdebug-client/ChangeLog
index 20ea47756b5f..00006741a4da 100644
--- a/dev-php/xdebug-client/ChangeLog
+++ b/dev-php/xdebug-client/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/xdebug-client
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/ChangeLog,v 1.55 2013/03/09 12:04:21 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/ChangeLog,v 1.56 2013/04/14 06:27:09 olemarkus Exp $
+
+*xdebug-client-2.2.2 (14 Apr 2013)
+
+ 14 Apr 2013; Ole Markus With <olemarkus@gentoo.org>
+ +xdebug-client-2.2.2.ebuild:
+ Version bump
09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> xdebug-client-2.2.1.ebuild:
Stable for ppc64, wrt bug #456598
diff --git a/dev-php/xdebug-client/xdebug-client-2.2.2.ebuild b/dev-php/xdebug-client/xdebug-client-2.2.2.ebuild
new file mode 100644
index 000000000000..4685eae42262
--- /dev/null
+++ b/dev-php/xdebug-client/xdebug-client-2.2.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/xdebug-client-2.2.2.ebuild,v 1.1 2013/04/14 06:27:09 olemarkus Exp $
+
+EAPI=4
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/rc/RC}"
+
+DESCRIPTION="Xdebug client for the Common Debugger Protocol (DBGP)."
+HOMEPAGE="http://www.xdebug.org/"
+SRC_URI="http://pecl.php.net/get/xdebug-${MY_PV}.tgz"
+LICENSE="Xdebug"
+SLOT="0"
+IUSE="libedit"
+
+S="${WORKDIR}/xdebug-${MY_PV}/debugclient"
+
+DEPEND="libedit? ( dev-libs/libedit )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf $(use_with libedit)
+}
+
+src_install() {
+ newbin debugclient xdebug
+}