summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2015-02-18 02:11:25 +0000
committerBrian Evans <grknight@gentoo.org>2015-02-18 02:11:25 +0000
commit8efca3caa8461c91668c8748d478cf226d9398f5 (patch)
treee6d6a88f77fc2d61fe4995debbaef832e98100ab /dev-php/doctrine
parentDrop old version with qt5 handling problems (diff)
downloadgentoo-2-8efca3caa8461c91668c8748d478cf226d9398f5.tar.gz
gentoo-2-8efca3caa8461c91668c8748d478cf226d9398f5.tar.bz2
gentoo-2-8efca3caa8461c91668c8748d478cf226d9398f5.zip
Add new slot for dev-php/doctrine and fix repoman warnings
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key 0xD1F781EFF9F4A3B6)
Diffstat (limited to 'dev-php/doctrine')
-rw-r--r--dev-php/doctrine/ChangeLog10
-rw-r--r--dev-php/doctrine/doctrine-1.2.5.ebuild6
-rw-r--r--dev-php/doctrine/doctrine-2.4.6.ebuild25
3 files changed, 36 insertions, 5 deletions
diff --git a/dev-php/doctrine/ChangeLog b/dev-php/doctrine/ChangeLog
index 7c67758831b0..90941633cf0f 100644
--- a/dev-php/doctrine/ChangeLog
+++ b/dev-php/doctrine/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/doctrine
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/doctrine/ChangeLog,v 1.4 2014/10/30 04:27:21 grknight Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/doctrine/ChangeLog,v 1.5 2015/02/18 02:11:25 grknight Exp $
+
+*doctrine-2.4.6 (18 Feb 2015)
+
+ 18 Feb 2015; Brian Evans <grknight@gentoo.org> +doctrine-2.4.6.ebuild,
+ doctrine-1.2.5.ebuild:
+ Add new slot for dev-php/doctrine and fix repoman warnings
*doctrine-1.2.5 (30 Oct 2014)
diff --git a/dev-php/doctrine/doctrine-1.2.5.ebuild b/dev-php/doctrine/doctrine-1.2.5.ebuild
index b1eb9f290b8c..fa4ac4bd15b4 100644
--- a/dev-php/doctrine/doctrine-1.2.5.ebuild
+++ b/dev-php/doctrine/doctrine-1.2.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/doctrine/doctrine-1.2.5.ebuild,v 1.1 2014/10/30 04:27:21 grknight Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/doctrine/doctrine-1.2.5.ebuild,v 1.2 2015/02/18 02:11:25 grknight Exp $
EAPI=5
@@ -14,7 +14,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND=">=dev-lang/php-5.2.3[cli,pdo]"
+DEPEND=">=dev-lang/php-5.2.3:*[cli,pdo]"
RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
diff --git a/dev-php/doctrine/doctrine-2.4.6.ebuild b/dev-php/doctrine/doctrine-2.4.6.ebuild
new file mode 100644
index 000000000000..11f1901d9066
--- /dev/null
+++ b/dev-php/doctrine/doctrine-2.4.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/doctrine/doctrine-2.4.6.ebuild,v 1.1 2015/02/18 02:11:25 grknight Exp $
+
+EAPI=5
+
+MY_P="${PN}2-${PV}"
+DESCRIPTION="An object relational mapper for PHP5"
+HOMEPAGE="http://www.doctrine-project.org/"
+SRC_URI="https://github.com/${PN}/${PN}2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1 MIT BSD"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/php-5.3.2:*[cli,pdo]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/share/php
+ doins -r lib/Doctrine
+}