summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Bergmann <sebastian@gentoo.org>2006-01-19 06:49:39 +0000
committerSebastian Bergmann <sebastian@gentoo.org>2006-01-19 06:49:39 +0000
commit00f45d2388bc2080574c332a18fb3bf707776b54 (patch)
treed36913e77d518033b3ebff009b84ca05f2f379c6 /dev-php/PECL-imagick
parentAdd missing fontconfig dependancy. See bug #119375. (diff)
downloadgentoo-2-00f45d2388bc2080574c332a18fb3bf707776b54.tar.gz
gentoo-2-00f45d2388bc2080574c332a18fb3bf707776b54.tar.bz2
gentoo-2-00f45d2388bc2080574c332a18fb3bf707776b54.zip
Backport graphicsmagick USE flag.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'dev-php/PECL-imagick')
-rw-r--r--dev-php/PECL-imagick/ChangeLog8
-rw-r--r--dev-php/PECL-imagick/PECL-imagick-0.9.11.ebuild12
2 files changed, 13 insertions, 7 deletions
diff --git a/dev-php/PECL-imagick/ChangeLog b/dev-php/PECL-imagick/ChangeLog
index 2d250c47f013..de1a2f6567b2 100644
--- a/dev-php/PECL-imagick/ChangeLog
+++ b/dev-php/PECL-imagick/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-php/PECL-imagick
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PECL-imagick/ChangeLog,v 1.11 2005/07/11 18:55:44 sebastian Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PECL-imagick/ChangeLog,v 1.12 2006/01/19 06:49:39 sebastian Exp $
+
+ 19 Jan 2006; Sebastian Bergmann <sebastian@gentoo.org>
+ PECL-imagick-0.9.11.ebuild:
+ Backport graphicsmagick USE flag.
11 Jul 2005; Sebastian Bergmann <sebastian@gentoo.org>
-PECL-imagick-0.9.8.ebuild, -PECL-imagick-0.9.8-r1.ebuild:
diff --git a/dev-php/PECL-imagick/PECL-imagick-0.9.11.ebuild b/dev-php/PECL-imagick/PECL-imagick-0.9.11.ebuild
index 3dcce9d7d72a..7eba3bb3ee16 100644
--- a/dev-php/PECL-imagick/PECL-imagick-0.9.11.ebuild
+++ b/dev-php/PECL-imagick/PECL-imagick-0.9.11.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PECL-imagick/PECL-imagick-0.9.11.ebuild,v 1.2 2005/02/14 16:54:52 sebastian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PECL-imagick/PECL-imagick-0.9.11.ebuild,v 1.3 2006/01/19 06:49:39 sebastian Exp $
PHP_EXT_ZENDEXT="no"
PHP_EXT_INI="yes"
inherit php-ext-pecl
-IUSE=""
+IUSE="graphicsmagick"
DESCRIPTION="PHP wrapper for the ImageMagick library."
HOMEPAGE="http://pecl.php.net/imagick"
SLOT="0"
@@ -15,10 +15,12 @@ LICENSE="PHP"
KEYWORDS="~x86"
DEPEND="${DEPEND}
- >=media-gfx/graphicsmagick-1.0.0"
+ !graphicsmagick? ( >=media-gfx/imagemagick-6.2.0 )
+ graphicsmagick? ( >=media-gfx/graphicsmagick-1.0.0 )"
src_compile () {
- myconf="--with-imagick --with-imagick-gm"
+ my_conf="--with-imagick"
+ use graphicsmagick && my_conf="${my_conf} --with-imagick-gm"
php-ext-pecl_src_compile
}