summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2008-07-04 08:52:23 +0000
committerTorsten Veller <tove@gentoo.org>2008-07-04 08:52:23 +0000
commitbd9957119ff0bea53ea015ffa34407256fb2493c (patch)
tree54a8ffc9177c912c12188cbf011b4c8b1045bb7d /dev-perl
parentkeyworded ~arch for x86, bug 230517 (diff)
downloadgentoo-2-bd9957119ff0bea53ea015ffa34407256fb2493c.tar.gz
gentoo-2-bd9957119ff0bea53ea015ffa34407256fb2493c.tar.bz2
gentoo-2-bd9957119ff0bea53ea015ffa34407256fb2493c.zip
Version bump (#228049)
(Portage version: 2.2_rc1/cvs/Linux 2.6.24-tuxonice-r9 i686)
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/libwww-perl/ChangeLog7
-rw-r--r--dev-perl/libwww-perl/libwww-perl-5.813.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-perl/libwww-perl/ChangeLog b/dev-perl/libwww-perl/ChangeLog
index a91f2373987a..c8f2040c2ca7 100644
--- a/dev-perl/libwww-perl/ChangeLog
+++ b/dev-perl/libwww-perl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/libwww-perl
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/ChangeLog,v 1.82 2008/06/07 12:06:22 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/ChangeLog,v 1.83 2008/07/04 08:52:23 tove Exp $
+
+*libwww-perl-5.813 (04 Jul 2008)
+
+ 04 Jul 2008; Torsten Veller <tove@gentoo.org> +libwww-perl-5.813.ebuild:
+ Version bump (#228049)
07 Jun 2008; Alexis Ballier <aballier@gentoo.org>
libwww-perl-5.812.ebuild:
diff --git a/dev-perl/libwww-perl/libwww-perl-5.813.ebuild b/dev-perl/libwww-perl/libwww-perl-5.813.ebuild
new file mode 100644
index 000000000000..40432d4208c6
--- /dev/null
+++ b/dev-perl/libwww-perl/libwww-perl-5.813.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/libwww-perl-5.813.ebuild,v 1.1 2008/07/04 08:52:23 tove Exp $
+
+MODULE_AUTHOR=GAAS
+inherit perl-module
+
+DESCRIPTION="A collection of Perl Modules for the WWW"
+IUSE="ssl"
+SLOT="0"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+
+DEPEND="virtual/perl-libnet
+ >=dev-perl/HTML-Parser-3.34
+ >=dev-perl/URI-1.10
+ >=virtual/perl-Digest-MD5-2.12
+ dev-perl/HTML-Tree
+ >=virtual/perl-MIME-Base64-2.12
+ >=dev-perl/Compress-Zlib-1.10
+ ssl? ( dev-perl/Crypt-SSLeay )
+ dev-lang/perl"
+
+src_compile() {
+ echo "y" | perl-module_src_compile
+}
+
+src_install() {
+ perl-module_src_install
+ dosym /usr/bin/lwp-request /usr/bin/GET
+ dosym /usr/bin/lwp-request /usr/bin/POST
+ dosym /usr/bin/lwp-request /usr/bin/HEAD
+}