summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2005-12-14 23:52:20 +0000
committerChris White <chriswhite@gentoo.org>2005-12-14 23:52:20 +0000
commita710c2edfca61a64214d0b1b94cef43ca61ee606 (patch)
tree6478ed69306afd103e413607593af588d4404e45 /dev-perl
parentRemoved dovecot masking as alphas 2 and 3 are no longer in portage (diff)
downloadgentoo-2-a710c2edfca61a64214d0b1b94cef43ca61ee606.tar.gz
gentoo-2-a710c2edfca61a64214d0b1b94cef43ca61ee606.tar.bz2
gentoo-2-a710c2edfca61a64214d0b1b94cef43ca61ee606.zip
Fix bug #115579. Ebuilds weren't compiling becaues they were trying to work with manpages which we no longer install.
(all your kde-base are belong to us version: 2.0.51.22-r3)
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/MP3-Tag/ChangeLog8
-rw-r--r--dev-perl/MP3-Tag/MP3-Tag-0.94.ebuild13
-rw-r--r--dev-perl/MP3-Tag/MP3-Tag-0.9702.ebuild11
-rw-r--r--dev-perl/MP3-Tag/Manifest8
-rw-r--r--dev-perl/MP3-Tag/files/MP3-Tag-0.94-makefile.patch14
-rw-r--r--dev-perl/MP3-Tag/files/MP3-Tag-0.9702-makefile.patch17
6 files changed, 61 insertions, 10 deletions
diff --git a/dev-perl/MP3-Tag/ChangeLog b/dev-perl/MP3-Tag/ChangeLog
index 570867e25b68..049b24998073 100644
--- a/dev-perl/MP3-Tag/ChangeLog
+++ b/dev-perl/MP3-Tag/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/MP3-Tag
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/MP3-Tag/ChangeLog,v 1.8 2005/11/27 22:23:56 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/MP3-Tag/ChangeLog,v 1.9 2005/12/14 23:52:20 chriswhite Exp $
+
+ 14 Dec 2005; Chris White <chriswhite@gentoo.org>
+ +files/MP3-Tag-0.94-makefile.patch, +files/MP3-Tag-0.9702-makefile.patch,
+ MP3-Tag-0.94.ebuild, MP3-Tag-0.9702.ebuild:
+ Fix bug #115579. Ebuilds weren't compiling becaues they were trying to work
+ with manpages which we no longer install.
27 Nov 2005; Tom Gall <tgall@gentoo.org> MP3-Tag-0.94.ebuild:
stable on ppc64
diff --git a/dev-perl/MP3-Tag/MP3-Tag-0.94.ebuild b/dev-perl/MP3-Tag/MP3-Tag-0.94.ebuild
index 2a0eab5ccce6..8622b1111311 100644
--- a/dev-perl/MP3-Tag/MP3-Tag-0.94.ebuild
+++ b/dev-perl/MP3-Tag/MP3-Tag-0.94.ebuild
@@ -1,17 +1,22 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/MP3-Tag/MP3-Tag-0.94.ebuild,v 1.8 2005/11/27 22:23:56 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/MP3-Tag/MP3-Tag-0.94.ebuild,v 1.9 2005/12/14 23:52:20 chriswhite Exp $
IUSE=""
-inherit perl-module
-
-S=${WORKDIR}/MP3-Tag-0.94
+inherit perl-module eutils
DESCRIPTION="Tag - Module for reading tags of mp3 files"
HOMEPAGE="http://www.cpan.org/modules/by-authors/id/I/IL/ILYAZ/modules/${P}.readme"
SRC_URI="mirror://cpan/modules/by-authors/id/I/IL/ILYAZ/modules/${P}.tar.gz"
+SRC_TEST="do"
SLOT="0"
LICENSE="Artistic"
KEYWORDS="amd64 ppc ppc64 sparc x86"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
diff --git a/dev-perl/MP3-Tag/MP3-Tag-0.9702.ebuild b/dev-perl/MP3-Tag/MP3-Tag-0.9702.ebuild
index 3a4f38201ee8..cf399439ed7d 100644
--- a/dev-perl/MP3-Tag/MP3-Tag-0.9702.ebuild
+++ b/dev-perl/MP3-Tag/MP3-Tag-0.9702.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/MP3-Tag/MP3-Tag-0.9702.ebuild,v 1.1 2005/11/19 12:30:35 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/MP3-Tag/MP3-Tag-0.9702.ebuild,v 1.2 2005/12/14 23:52:20 chriswhite Exp $
IUSE=""
-inherit perl-module
+inherit perl-module eutils
DESCRIPTION="Tag - Module for reading tags of mp3 files"
HOMEPAGE="http://www.cpan.org/modules/by-authors/id/I/IL/ILYAZ/modules/${P}.readme"
@@ -13,3 +13,10 @@ SRC_URI="mirror://cpan/modules/by-authors/id/I/IL/ILYAZ/modules/${P}.tar.gz"
SLOT="0"
LICENSE="Artistic"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+SRC_TEST="do"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
diff --git a/dev-perl/MP3-Tag/Manifest b/dev-perl/MP3-Tag/Manifest
index cea57494e0dd..e932b39df08f 100644
--- a/dev-perl/MP3-Tag/Manifest
+++ b/dev-perl/MP3-Tag/Manifest
@@ -1,6 +1,8 @@
-MD5 2e02c49e89ffb144f8c36097162a296b ChangeLog 993
-MD5 779c02026a62c2c4b2b71b5ccbb1e09f MP3-Tag-0.94.ebuild 559
-MD5 137541ce32f90dca767d7058d5380f86 MP3-Tag-0.9702.ebuild 543
MD5 e434304178ece613e83dbf21445ffaa2 metadata.xml 178
+MD5 00f95f211f057b2f085e6abf45b933b7 MP3-Tag-0.94.ebuild 637
+MD5 769145a6600899d7334f056ab332524a MP3-Tag-0.9702.ebuild 648
+MD5 2e02c49e89ffb144f8c36097162a296b ChangeLog 993
+MD5 de9ecb5a9fdf27e5315b3a4b5a1f7660 files/MP3-Tag-0.9702-makefile.patch 558
MD5 9a8c502af9b00ed6acbeb828096d7a16 files/digest-MP3-Tag-0.94 63
+MD5 4f18b28383f4c65840a1225929a2e298 files/MP3-Tag-0.94-makefile.patch 490
MD5 cd5fdd0cf47b5fec982e097c625557ca files/digest-MP3-Tag-0.9702 66
diff --git a/dev-perl/MP3-Tag/files/MP3-Tag-0.94-makefile.patch b/dev-perl/MP3-Tag/files/MP3-Tag-0.94-makefile.patch
new file mode 100644
index 000000000000..68e489ca74a0
--- /dev/null
+++ b/dev-perl/MP3-Tag/files/MP3-Tag-0.94-makefile.patch
@@ -0,0 +1,14 @@
+--- Makefile.PL.old 2005-12-15 08:37:36.000000000 +0900
++++ Makefile.PL 2005-12-15 08:37:47.000000000 +0900
+@@ -12,11 +12,3 @@
+ 'PL_FILES' => {'data_pod.PL'=>'ID3v2-Data.pod'},
+ 'clean' => {FILES => 'ID3v2-Data.pod'},
+ );
+-
+-# Tell MakeMaker about manifying ID3v2-Data.pod
+-package MY;
+-sub manifypods {
+- my $self = shift;
+- $self->{MAN3PODS}->{'ID3v2-Data.pod'} = '$(INST_MAN3DIR)/MP3::Tag::ID3v2-Data.$(MAN3EXT)';
+- $self->SUPER::manifypods(@_);
+-}
diff --git a/dev-perl/MP3-Tag/files/MP3-Tag-0.9702-makefile.patch b/dev-perl/MP3-Tag/files/MP3-Tag-0.9702-makefile.patch
new file mode 100644
index 000000000000..1b7873a67375
--- /dev/null
+++ b/dev-perl/MP3-Tag/files/MP3-Tag-0.9702-makefile.patch
@@ -0,0 +1,17 @@
+--- Makefile.PL.old 2005-12-15 08:45:16.000000000 +0900
++++ Makefile.PL 2005-12-15 08:45:49.000000000 +0900
+@@ -35,14 +35,6 @@
+ 'clean' => {FILES => 'ID3v2-Data.pod'},
+ );
+
+-# Tell MakeMaker about manifying ID3v2-Data.pod
+-package MY;
+-sub manifypods {
+- my $self = shift;
+- $self->{MAN3PODS}->{'ID3v2-Data.pod'} = '$(INST_MAN3DIR)/MP3::Tag::ID3v2-Data.$(MAN3EXT)';
+- $self->SUPER::manifypods(@_);
+-}
+-
+ sub postamble { # Not good enough: is done after .pod is moved to INST_LIB...
+ '
+ ID3v2-Data.pod :: Tag/ID3v2.pm # pm_to_blib