summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2009-07-16 09:13:09 +0000
committerTorsten Veller <tove@gentoo.org>2009-07-16 09:13:09 +0000
commit73488a11e1896cabd896a74b60c60841ee276a63 (patch)
tree67ec8cac5429b2fd62e210a73647a3adf97a00fc /dev-perl
parentCleanup (diff)
downloadgentoo-2-73488a11e1896cabd896a74b60c60841ee276a63.tar.gz
gentoo-2-73488a11e1896cabd896a74b60c60841ee276a63.tar.bz2
gentoo-2-73488a11e1896cabd896a74b60c60841ee276a63.zip
Cleanup
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/GD/ChangeLog6
-rw-r--r--dev-perl/GD/GD-2.41.ebuild71
-rw-r--r--dev-perl/GD/GD-2.43.ebuild56
3 files changed, 5 insertions, 128 deletions
diff --git a/dev-perl/GD/ChangeLog b/dev-perl/GD/ChangeLog
index c40cd6c689ba..2f6fedec1ac9 100644
--- a/dev-perl/GD/ChangeLog
+++ b/dev-perl/GD/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-perl/GD
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/GD/ChangeLog,v 1.82 2009/07/11 07:06:40 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/GD/ChangeLog,v 1.83 2009/07/16 09:13:09 tove Exp $
+
+ 16 Jul 2009; Torsten Veller <tove@gentoo.org> -GD-2.41.ebuild,
+ -GD-2.43.ebuild:
+ Cleanup
*GD-2.44 (11 Jul 2009)
diff --git a/dev-perl/GD/GD-2.41.ebuild b/dev-perl/GD/GD-2.41.ebuild
deleted file mode 100644
index 67427072e820..000000000000
--- a/dev-perl/GD/GD-2.41.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/GD/GD-2.41.ebuild,v 1.1 2008/09/10 17:12:12 tove Exp $
-
-MODULE_AUTHOR=LDS
-inherit eutils perl-module
-
-DESCRIPTION="interface to Thomas Boutell's gd library"
-
-LICENSE="|| ( Artistic GPL-2 )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="animgif gif jpeg png truetype xpm"
-
-DEPEND=">=media-libs/gd-2.0.33
- png? ( media-libs/libpng sys-libs/zlib )
- jpeg? ( media-libs/jpeg )
- truetype? ( =media-libs/freetype-2* )
- xpm? ( x11-libs/libXpm )
- gif? ( media-libs/giflib )
- dev-lang/perl"
-
- SRC_TEST=do
-
-pkg_setup() {
- local i_can_has_die=0
-
- if use jpeg && ! built_with_use media-libs/gd jpeg; then
- echo
- eerror "If you want to compile dev-perl/GD with USE=jpeg, you must first"
- eerror "compile media-libs/gd with USE=jpeg"
- i_can_has_die=1
- fi
-
- if use truetype && ! built_with_use media-libs/gd truetype; then
- echo
- eerror "If you want to compile dev-perl/GD with USE=truetype, you must first"
- eerror "compile media-libs/gd with USE=truetype"
- i_can_has_die=1
- fi
-
- if use png && ! built_with_use media-libs/gd png; then
- echo
- eerror "If you want to compile dev-perl/GD with USE=png, you must first"
- eerror "compile media-libs/gd with USE=png"
- i_can_has_die=1
- fi
-
- if use xpm && ! built_with_use media-libs/gd xpm; then
- echo
- eerror "If you want to compile dev-perl/GD with USE=xpm, you must first"
- eerror "compile media-libs/gd with USE=xpm"
- i_can_has_die=1
- fi
-
- [[ ${i_can_has_die} -ne 0 ]] && die "Please fix the errors above before continuing"
-}
-
-src_compile() {
- myconf=""
- use gif && use animgif && myconf="${myconf},ANIMGIF"
- use jpeg && myconf="${myconf},JPEG"
- use truetype && myconf="${myconf},FREETYPE"
- use png && myconf="${myconf},PNG"
- use xpm && myconf="${myconf},XPM"
- use gif && myconf="${myconf},GIF"
- myconf="-options \"${myconf:1}\""
- perl-module_src_compile
-}
-
-mydoc="GD.html"
diff --git a/dev-perl/GD/GD-2.43.ebuild b/dev-perl/GD/GD-2.43.ebuild
deleted file mode 100644
index 33a36c306bbb..000000000000
--- a/dev-perl/GD/GD-2.43.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/GD/GD-2.43.ebuild,v 1.1 2009/06/12 07:37:51 tove Exp $
-
-EAPI=2
-
-MODULE_AUTHOR=LDS
-inherit perl-module
-
-DESCRIPTION="interface to Thomas Boutell's gd library"
-
-LICENSE="|| ( Artistic-2 GPL-2 )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="animgif gif jpeg png truetype xpm"
-
-DEPEND=">=media-libs/gd-2.0.33
- png? (
- media-libs/gd[png]
- media-libs/libpng
- sys-libs/zlib
- )
- jpeg? (
- media-libs/gd[jpeg]
- media-libs/jpeg
- )
- truetype? (
- media-libs/gd[truetype]
- media-libs/freetype:2
- )
- xpm? (
- media-libs/gd[xpm]
- x11-libs/libXpm
- )
- gif? ( media-libs/giflib )"
-
- SRC_TEST=do
-
-src_prepare(){
- perl-module_src_prepare
- sed -i "s/use Getopt::Long;/use Getopt::Long qw(:config pass_through);/" \
- "${S}"/Makefile.PL || die
-}
-src_configure() {
- myconf=""
- use gif && use animgif && myconf="${myconf},ANIMGIF"
- use jpeg && myconf="${myconf},JPEG"
- use truetype && myconf="${myconf},FREETYPE"
- use png && myconf="${myconf},PNG"
- use xpm && myconf="${myconf},XPM"
- use gif && myconf="${myconf},GIF"
- myconf="-options \"${myconf:1}\""
- perl-module_src_configure
-}
-
-mydoc="GD.html"