summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2006-01-13 17:21:26 +0000
committerMichael Cummings <mcummings@gentoo.org>2006-01-13 17:21:26 +0000
commit6d3795147b88d2ec222fa414f3980f24b1b011b0 (patch)
tree11b28e85d97c6528ea6c65ef9ad45054b3f5de62 /dev-perl/wxperl/wxperl-0.27.ebuild
parent=dev-lisp/clisp-2.37 OPEN ... :IF-EXISTS :APPEND causes data loss (diff)
downloadgentoo-2-6d3795147b88d2ec222fa414f3980f24b1b011b0.tar.gz
gentoo-2-6d3795147b88d2ec222fa414f3980f24b1b011b0.tar.bz2
gentoo-2-6d3795147b88d2ec222fa414f3980f24b1b011b0.zip
Version bump upstream
(Portage version: 2.1_pre1)
Diffstat (limited to 'dev-perl/wxperl/wxperl-0.27.ebuild')
-rw-r--r--dev-perl/wxperl/wxperl-0.27.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/wxperl/wxperl-0.27.ebuild b/dev-perl/wxperl/wxperl-0.27.ebuild
new file mode 100644
index 000000000000..863dcf5f3fd9
--- /dev/null
+++ b/dev-perl/wxperl/wxperl-0.27.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/wxperl/wxperl-0.27.ebuild,v 1.1 2006/01/13 17:21:26 mcummings Exp $
+
+inherit perl-module eutils wxwidgets
+
+MY_P="Wx-${PV}"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Perl bindings for wxGTK"
+HOMEPAGE="http://wxperl.sourceforge.net/"
+SRC_URI="mirror://cpan/authors/id/M/MB/MBARBON/${MY_P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="unicode"
+
+DEPEND="x11-libs/wxGTK
+ >=dev-lang/perl-5.8.4
+ >=perl-core/File-Spec-0.82
+ !=perl-core/ExtUtils-MakeMaker-6.21"
+
+src_compile() {
+ WX_GTK_VER="2.6"
+ if use unicode; then
+ need-wxwidgets unicode
+ else
+ need-wxwidgets gtk2
+ fi
+ perl-module_src_compile
+}