summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2007-04-16 13:11:41 +0000
committerMichael Cummings <mcummings@gentoo.org>2007-04-16 13:11:41 +0000
commita6b496bd00c51d70698252cd33447ac937c0a9e8 (patch)
treedcf01d8eef5cec490c3ba97939c5f8c4d4ea735a /dev-perl/module-build
parentStable on sparc wrt security #174043 (diff)
downloadgentoo-2-a6b496bd00c51d70698252cd33447ac937c0a9e8.tar.gz
gentoo-2-a6b496bd00c51d70698252cd33447ac937c0a9e8.tar.bz2
gentoo-2-a6b496bd00c51d70698252cd33447ac937c0a9e8.zip
Version bump
(Portage version: 2.1.2.3)
Diffstat (limited to 'dev-perl/module-build')
-rw-r--r--dev-perl/module-build/ChangeLog8
-rw-r--r--dev-perl/module-build/files/digest-module-build-0.28.073
-rw-r--r--dev-perl/module-build/module-build-0.28.07.ebuild30
3 files changed, 40 insertions, 1 deletions
diff --git a/dev-perl/module-build/ChangeLog b/dev-perl/module-build/ChangeLog
index 9b20dc6e21e7..80dd0a2a377f 100644
--- a/dev-perl/module-build/ChangeLog
+++ b/dev-perl/module-build/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/module-build
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/module-build/ChangeLog,v 1.61 2007/04/16 07:16:16 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/module-build/ChangeLog,v 1.62 2007/04/16 13:11:41 mcummings Exp $
+
+*module-build-0.28.07 (16 Apr 2007)
+
+ 16 Apr 2007; Michael Cummings <mcummings@gentoo.org>
+ +module-build-0.28.07.ebuild:
+ Version bump
16 Apr 2007; Markus Rothe <corsair@gentoo.org>
module-build-0.28.05.ebuild:
diff --git a/dev-perl/module-build/files/digest-module-build-0.28.07 b/dev-perl/module-build/files/digest-module-build-0.28.07
new file mode 100644
index 000000000000..783583e290a7
--- /dev/null
+++ b/dev-perl/module-build/files/digest-module-build-0.28.07
@@ -0,0 +1,3 @@
+MD5 6766157e8f4ae5ce6d58653271c42ad7 Module-Build-0.2807.tar.gz 194196
+RMD160 7dd0d894393debc5b9cda82d2d7d483923df4beb Module-Build-0.2807.tar.gz 194196
+SHA256 eba3eab53cfefd16769cdc2b7ae34b447d9b0c8eb8097af8463d921587f76bab Module-Build-0.2807.tar.gz 194196
diff --git a/dev-perl/module-build/module-build-0.28.07.ebuild b/dev-perl/module-build/module-build-0.28.07.ebuild
new file mode 100644
index 000000000000..c884e135b7ce
--- /dev/null
+++ b/dev-perl/module-build/module-build-0.28.07.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/module-build/module-build-0.28.07.ebuild,v 1.1 2007/04/16 13:11:41 mcummings Exp $
+
+inherit versionator perl-module
+
+MY_PV="$(delete_version_separator 2)"
+MY_P="Module-Build-${MY_PV}"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Build and install Perl modules"
+HOMEPAGE="http://search.cpan.org/~kwilliams/"
+SRC_URI="mirror://cpan/authors/id/K/KW/KWILLIAMS/${MY_P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="test"
+
+# Removing these as hard deps. They are listed as recommended in the Build.PL,
+# but end up causing a dep loop since they require module-build to be built.
+# ~mcummings 06.16.06
+PDEPEND=">=dev-perl/ExtUtils-CBuilder-0.15
+ >=dev-perl/extutils-parsexs-1.02"
+
+DEPEND="dev-lang/perl
+ dev-perl/yaml
+ test? ( <dev-perl/version-0.72.01 )
+ >=dev-perl/Archive-Tar-1.09"
+
+SRC_TEST="do"