summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2007-05-12 14:42:21 +0000
committerMichael Cummings <mcummings@gentoo.org>2007-05-12 14:42:21 +0000
commit072011e9cd61f5b72026c9cbc95464f8af4de071 (patch)
tree87a7ceb3bec861527894277e5e0a92d0814ee9f1 /dev-perl/Snowball-Swedish/Snowball-Swedish-1.2.ebuild
parentVersion bump (diff)
downloadgentoo-2-072011e9cd61f5b72026c9cbc95464f8af4de071.tar.gz
gentoo-2-072011e9cd61f5b72026c9cbc95464f8af4de071.tar.bz2
gentoo-2-072011e9cd61f5b72026c9cbc95464f8af4de071.zip
Version bump
(Portage version: 2.1.2.3)
Diffstat (limited to 'dev-perl/Snowball-Swedish/Snowball-Swedish-1.2.ebuild')
-rw-r--r--dev-perl/Snowball-Swedish/Snowball-Swedish-1.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-perl/Snowball-Swedish/Snowball-Swedish-1.2.ebuild b/dev-perl/Snowball-Swedish/Snowball-Swedish-1.2.ebuild
new file mode 100644
index 000000000000..02fb92b928bb
--- /dev/null
+++ b/dev-perl/Snowball-Swedish/Snowball-Swedish-1.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Snowball-Swedish/Snowball-Swedish-1.2.ebuild,v 1.1 2007/05/12 14:42:21 mcummings Exp $
+
+inherit perl-module multilib
+
+DESCRIPTION="Porters stemming algorithm for Swedish"
+HOMEPAGE="http://search.cpan.org/~asksh/"
+SRC_URI="mirror://cpan/authors/id/A/AS/ASKSH/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+SRC_TEST="do"
+
+
+DEPEND="dev-lang/perl"
+
+src_install() {
+ perl-module_src_install
+ local version
+ eval `perl '-V:version'`
+ perl_version=${version}
+ local myarch
+ eval `perl '-V:archname'`
+ myarch=${archname}
+
+ if [ -f ${D}/usr/$(get_libdir)/perl5/vendor_perl/${perl_version}/Lingua/Stem/Snowball/stemmer.pl ]; then
+ mv \
+ ${D}/usr/$(get_libdir)/perl5/vendor_perl/${perl_version}/Lingua/Stem/Snowball/stemmer.pl \
+ ${D}/usr/$(get_libdir)/perl5/vendor_perl/${perl_version}/Lingua/Stem/Snowball/se-stemmer.pl
+ fi
+}
+
+pkg_postinst() {
+ perl-module_pkg_postinst
+ elog "The stemmer.pl that ships with this distribution has been renamed to"
+ elog "se-stemmer.pl to avoid collisions with other Lingua::Stem packages."
+}