summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2011-09-01 14:07:20 +0000
committerTorsten Veller <tove@gentoo.org>2011-09-01 14:07:20 +0000
commit70afc3594cd2bba01a301690387fd9a705370e33 (patch)
treeb49ca3db908f9c284da5d2c67b76f8aab6238d6b /dev-perl/RPC-XML
parentChange version scheme (diff)
downloadgentoo-2-70afc3594cd2bba01a301690387fd9a705370e33.tar.gz
gentoo-2-70afc3594cd2bba01a301690387fd9a705370e33.tar.bz2
gentoo-2-70afc3594cd2bba01a301690387fd9a705370e33.zip
Change version scheme
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/RPC-XML')
-rw-r--r--dev-perl/RPC-XML/ChangeLog7
-rw-r--r--dev-perl/RPC-XML/RPC-XML-0.740.0.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-perl/RPC-XML/ChangeLog b/dev-perl/RPC-XML/ChangeLog
index a8f421792f82..091019190292 100644
--- a/dev-perl/RPC-XML/ChangeLog
+++ b/dev-perl/RPC-XML/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/RPC-XML
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/RPC-XML/ChangeLog,v 1.58 2011/02/09 16:57:26 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/RPC-XML/ChangeLog,v 1.59 2011/09/01 14:07:20 tove Exp $
+
+*RPC-XML-0.740.0 (01 Sep 2011)
+
+ 01 Sep 2011; Torsten Veller <tove@gentoo.org> +RPC-XML-0.740.0.ebuild:
+ Change version scheme
*RPC-XML-0.740 (24 Jan 2011)
diff --git a/dev-perl/RPC-XML/RPC-XML-0.740.0.ebuild b/dev-perl/RPC-XML/RPC-XML-0.740.0.ebuild
new file mode 100644
index 000000000000..d25a5ce22561
--- /dev/null
+++ b/dev-perl/RPC-XML/RPC-XML-0.740.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/RPC-XML/RPC-XML-0.740.0.ebuild,v 1.1 2011/09/01 14:07:20 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=RJRAY
+MODULE_VERSION=0.74
+inherit perl-module
+
+DESCRIPTION="An implementation of XML-RPC"
+
+SLOT="0"
+LICENSE="|| ( Artistic-2 LGPL-2.1 )"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+SRC_TEST="do"
+
+RDEPEND=">=dev-perl/libwww-perl-5.834
+ >=dev-perl/XML-LibXML-1.70
+ >=dev-perl/XML-Parser-2.31
+ dev-perl/net-server
+ >=virtual/perl-Scalar-List-Utils-1.20"
+DEPEND="${RDEPEND}"
+
+pkg_postinst() {
+ perl-module_pkg_postinst
+
+ SETWARN=0
+ has_version '=www-servers/apache-2*' && HAVE_APACHE2=1
+ has_version '>=www-apache/mod_perl-2.0' && HAVE_MP2=2
+
+ [ -n "${HAVE_APACHE2}" ] && SETWARN=1
+ [ -n "${HAVE_MP2}" ] && SETWARN=1
+
+ if [ "$SETWARN" == "1" ]; then
+ ewarn "Apache2 or mod_perl2 were detected."
+ ewarn ""
+ ewarn "NOTE FROM THE AUTHOR OF RPC-XML"
+ ewarn ""
+ ewarn "At present, this package does not work with Apache2 and the soon-to-be"
+ ewarn "mod_perl2. The changes to the API for location handlers are too drastic to"
+ ewarn "try and support both within the same class (I tried, using the compatibility"
+ ewarn "layer). Also, mp2 does not currently provide support for <Perl> sections, which"
+ ewarn "are the real strength of the Apache::RPC::Server class."
+ fi
+}