summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2013-02-21 16:15:54 +0000
committerTorsten Veller <tove@gentoo.org>2013-02-21 16:15:54 +0000
commitc1ddf1c381a747d8697479e9014ab9892edbf8a4 (patch)
tree80e2d858ba742e5305a415522cea52cae3b97b5f /dev-perl/Net-SSH2/Net-SSH2-0.480.0.ebuild
parent[bump] dev-perl/Path-Tiny-0.12.0 (diff)
downloadgentoo-2-c1ddf1c381a747d8697479e9014ab9892edbf8a4.tar.gz
gentoo-2-c1ddf1c381a747d8697479e9014ab9892edbf8a4.tar.bz2
gentoo-2-c1ddf1c381a747d8697479e9014ab9892edbf8a4.zip
[bump] dev-perl/Net-SSH2-0.480.0
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 0x5772769F4E046AEC)
Diffstat (limited to 'dev-perl/Net-SSH2/Net-SSH2-0.480.0.ebuild')
-rw-r--r--dev-perl/Net-SSH2/Net-SSH2-0.480.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-perl/Net-SSH2/Net-SSH2-0.480.0.ebuild b/dev-perl/Net-SSH2/Net-SSH2-0.480.0.ebuild
new file mode 100644
index 000000000000..ef6f8cbe94b0
--- /dev/null
+++ b/dev-perl/Net-SSH2/Net-SSH2-0.480.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-SSH2/Net-SSH2-0.480.0.ebuild,v 1.1 2013/02/21 16:15:54 tove Exp $
+
+EAPI=5
+
+MODULE_AUTHOR=RKITOVER
+MODULE_VERSION=0.48
+inherit perl-module
+
+DESCRIPTION="Net::SSH2 - Support for the SSH 2 protocol via libssh2."
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gcrypt"
+
+RDEPEND="
+ sys-libs/zlib
+ net-libs/libssh2
+ !gcrypt? (
+ dev-libs/openssl
+ )
+ gcrypt? (
+ dev-libs/libgcrypt
+ )
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.50
+"
+
+SRC_TEST="do"
+
+src_configure() {
+ use gcrypt && myconf=gcrypt
+ perl-module_src_configure
+}