summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2013-06-19 23:15:03 +0000
committerMikle Kolyada <zlogene@gentoo.org>2013-06-19 23:15:03 +0000
commitf8a6ebba1b320800a99dea1c46bc3c2810df759c (patch)
treeee68289235e04e96e9427fc4e491f026db2ef91c /dev-perl/Net-Patricia
parentAdd to tree from kde overlay (diff)
downloadgentoo-2-f8a6ebba1b320800a99dea1c46bc3c2810df759c.tar.gz
gentoo-2-f8a6ebba1b320800a99dea1c46bc3c2810df759c.tar.bz2
gentoo-2-f8a6ebba1b320800a99dea1c46bc3c2810df759c.zip
respect AR wrt bug #473876
(Portage version: 2.1.12.2/cvs/Linux i686, signed Manifest commit with key 0xC42EB5D6)
Diffstat (limited to 'dev-perl/Net-Patricia')
-rw-r--r--dev-perl/Net-Patricia/ChangeLog7
-rw-r--r--dev-perl/Net-Patricia/Net-Patricia-1.200.0.ebuild12
2 files changed, 14 insertions, 5 deletions
diff --git a/dev-perl/Net-Patricia/ChangeLog b/dev-perl/Net-Patricia/ChangeLog
index 7dea6f309aec..c52f4e989ed2 100644
--- a/dev-perl/Net-Patricia/ChangeLog
+++ b/dev-perl/Net-Patricia/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-perl/Net-Patricia
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-Patricia/ChangeLog,v 1.31 2012/10/09 17:27:51 tove Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-Patricia/ChangeLog,v 1.32 2013/06/19 23:15:03 zlogene Exp $
+
+ 19 Jun 2013; Mikle Kolyada <zlogene@gentoo.org> Net-Patricia-1.200.0.ebuild:
+ respect AR wrt bug #473876
*Net-Patricia-1.200.0 (09 Oct 2012)
diff --git a/dev-perl/Net-Patricia/Net-Patricia-1.200.0.ebuild b/dev-perl/Net-Patricia/Net-Patricia-1.200.0.ebuild
index 4d398ef910e7..6b2743c2ce67 100644
--- a/dev-perl/Net-Patricia/Net-Patricia-1.200.0.ebuild
+++ b/dev-perl/Net-Patricia/Net-Patricia-1.200.0.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-Patricia/Net-Patricia-1.200.0.ebuild,v 1.1 2012/10/09 17:27:51 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-Patricia/Net-Patricia-1.200.0.ebuild,v 1.2 2013/06/19 23:15:03 zlogene Exp $
EAPI=4
MODULE_AUTHOR=GRUBER
MODULE_VERSION=1.20
-inherit perl-module
+inherit perl-module toolchain-funcs
DESCRIPTION="Patricia Trie perl module for fast IP address lookups"
@@ -22,4 +22,10 @@ RDEPEND="dev-perl/Net-CIDR-Lite
"
DEPEND="${RDEPEND}"
+src_compile() {
+ emake AR="$(tc-getAR)" OTHERLDFLAGS="${LDFLAGS}"
+
+ perl-module_src_compile
+}
+
#SRC_TEST="do"