summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-09-13 05:31:13 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-09-13 05:31:13 +0000
commitb7eda8cebb5df37fa3f48449dbfc874e791bf58a (patch)
treeaecae5db92f3630b3c1be549a0e08da2b7f6c10c /dev-perl/Net-Patricia
parentBump aeson to 0.6.2.0 (diff)
downloadgentoo-2-b7eda8cebb5df37fa3f48449dbfc874e791bf58a.tar.gz
gentoo-2-b7eda8cebb5df37fa3f48449dbfc874e791bf58a.tar.bz2
gentoo-2-b7eda8cebb5df37fa3f48449dbfc874e791bf58a.zip
Bump
(Portage version: 2.2.3/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-perl/Net-Patricia')
-rw-r--r--dev-perl/Net-Patricia/ChangeLog7
-rw-r--r--dev-perl/Net-Patricia/Net-Patricia-1.210.0.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-perl/Net-Patricia/ChangeLog b/dev-perl/Net-Patricia/ChangeLog
index 0491f17951d0..38adcb706e54 100644
--- a/dev-perl/Net-Patricia/ChangeLog
+++ b/dev-perl/Net-Patricia/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/Net-Patricia
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-Patricia/ChangeLog,v 1.34 2013/06/19 23:26:11 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-Patricia/ChangeLog,v 1.35 2013/09/13 05:31:13 patrick Exp $
+
+*Net-Patricia-1.210.0 (13 Sep 2013)
+
+ 13 Sep 2013; Patrick Lauer <patrick@gentoo.org> +Net-Patricia-1.210.0.ebuild:
+ Bump
19 Jun 2013; Mikle Kolyada <zlogene@gentoo.org> -Net-Patricia-1.190.0.ebuild:
drop old
diff --git a/dev-perl/Net-Patricia/Net-Patricia-1.210.0.ebuild b/dev-perl/Net-Patricia/Net-Patricia-1.210.0.ebuild
new file mode 100644
index 000000000000..c70299d228ea
--- /dev/null
+++ b/dev-perl/Net-Patricia/Net-Patricia-1.210.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-Patricia/Net-Patricia-1.210.0.ebuild,v 1.1 2013/09/13 05:31:13 patrick Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=GRUBER
+MODULE_VERSION=1.21
+inherit perl-module toolchain-funcs
+
+DESCRIPTION="Patricia Trie perl module for fast IP address lookups"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="ipv6"
+
+RDEPEND="dev-perl/Net-CIDR-Lite
+ ipv6? (
+ dev-perl/Socket6
+ )
+"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake AR="$(tc-getAR)" OTHERLDFLAGS="${LDFLAGS}"
+}
+
+#SRC_TEST="do"