summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-09-25 19:02:24 +0000
committerAchim Gottinger <achim@gentoo.org>2001-09-25 19:02:24 +0000
commitebeca9534a3844a30562777281b8cc2e1f4884ab (patch)
tree1096fd31b6ccdb873e323de9052eb6ca13e7ae48 /dev-perl/HTML-Object
parentlots of new incoming stuff (diff)
downloadgentoo-2-ebeca9534a3844a30562777281b8cc2e1f4884ab.tar.gz
gentoo-2-ebeca9534a3844a30562777281b8cc2e1f4884ab.tar.bz2
gentoo-2-ebeca9534a3844a30562777281b8cc2e1f4884ab.zip
The HTML Document Object allows you as a programmer to quickly and easily
generate dynamic HTML documents without having to deal with all the HTML overhead at every step of the way. For example, you have the ability to generate a cookie at any point, until you actually display the document.
Diffstat (limited to 'dev-perl/HTML-Object')
-rw-r--r--dev-perl/HTML-Object/HTML-Object-2.10.ebuild26
-rw-r--r--dev-perl/HTML-Object/files/digest-HTML-Object-2.101
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-perl/HTML-Object/HTML-Object-2.10.ebuild b/dev-perl/HTML-Object/HTML-Object-2.10.ebuild
new file mode 100644
index 000000000000..9548ef26a575
--- /dev/null
+++ b/dev-perl/HTML-Object/HTML-Object-2.10.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jerry Alexandratos <jerry@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Object/HTML-Object-2.10.ebuild,v 1.1 2001/09/25 19:02:24 achim Exp $
+
+P=html_object-${PV}
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="A HTML development and delivery Perl Module"
+SRC_URI="http://prdownloads.sourceforge.net/htmlobject/${A}"
+HOMEPAGE="http://htmlobject.sourceforge.net"
+DEPEND=">=sys-devel/perl-5"
+
+src_compile() {
+
+ perl Makefile.PL
+ try make
+
+}
+
+src_install () {
+
+ try make PREFIX=${D}/usr INSTALLMAN3DIR=${D}/usr/share/man/man3 install
+ dodoc Changes LICENSE MANIFEST README TODO
+
+}
diff --git a/dev-perl/HTML-Object/files/digest-HTML-Object-2.10 b/dev-perl/HTML-Object/files/digest-HTML-Object-2.10
new file mode 100644
index 000000000000..9425db81ef0f
--- /dev/null
+++ b/dev-perl/HTML-Object/files/digest-HTML-Object-2.10
@@ -0,0 +1 @@
+MD5 f53488430bee12e72c88512fd6d87a11 html_object-2.10.tar.gz