summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2011-09-21 02:07:02 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2011-09-21 02:07:02 +0000
commit8115bc9b08c3db4ee9679cfc0fb5e9ae7dde7beb (patch)
tree6689b3f0aac779968cb173fe7a541d0a60b0675c /dev-perl/HTML-Mason
parentDev channel version bump. Convert to new slotting system. (diff)
downloadgentoo-2-8115bc9b08c3db4ee9679cfc0fb5e9ae7dde7beb.tar.gz
gentoo-2-8115bc9b08c3db4ee9679cfc0fb5e9ae7dde7beb.tar.bz2
gentoo-2-8115bc9b08c3db4ee9679cfc0fb5e9ae7dde7beb.zip
Version bump via perl-bump experimental tool.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/HTML-Mason')
-rw-r--r--dev-perl/HTML-Mason/ChangeLog8
-rw-r--r--dev-perl/HTML-Mason/HTML-Mason-1.460.0.ebuild62
2 files changed, 69 insertions, 1 deletions
diff --git a/dev-perl/HTML-Mason/ChangeLog b/dev-perl/HTML-Mason/ChangeLog
index aed187e4d569..977fe984edb7 100644
--- a/dev-perl/HTML-Mason/ChangeLog
+++ b/dev-perl/HTML-Mason/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/HTML-Mason
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/ChangeLog,v 1.99 2011/09/04 11:22:52 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/ChangeLog,v 1.100 2011/09/21 02:07:01 robbat2 Exp $
+
+*HTML-Mason-1.460.0 (21 Sep 2011)
+
+ 21 Sep 2011; Robin H. Johnson <robbat2@gentoo.org>
+ +HTML-Mason-1.460.0.ebuild:
+ Version bump via perl-bump experimental tool.
04 Sep 2011; Torsten Veller <tove@gentoo.org> -HTML-Mason-1.45.ebuild:
Cleanup
diff --git a/dev-perl/HTML-Mason/HTML-Mason-1.460.0.ebuild b/dev-perl/HTML-Mason/HTML-Mason-1.460.0.ebuild
new file mode 100644
index 000000000000..e0fbe29a6c3d
--- /dev/null
+++ b/dev-perl/HTML-Mason/HTML-Mason-1.460.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/HTML-Mason-1.460.0.ebuild,v 1.1 2011/09/21 02:07:02 robbat2 Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=JSWARTZ
+MODULE_VERSION=1.46
+inherit depend.apache perl-module
+
+DESCRIPTION="A HTML development and delivery Perl Module"
+HOMEPAGE="http://www.masonhq.com/ ${HOMEPAGE}"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="modperl doc test"
+
+RDEPEND="!modperl? ( virtual/perl-CGI )
+ modperl? (
+ www-apache/libapreq2
+ >=www-apache/mod_perl-2
+ )
+ >=dev-perl/Params-Validate-0.7
+ >=dev-perl/Class-Container-0.08
+ >=dev-perl/Exception-Class-1.15
+ dev-perl/HTML-Parser
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-File-Spec
+ >=dev-perl/Cache-Cache-1.01
+ dev-perl/Log-Any"
+
+DEPEND="${RDEPEND}
+ virtual/perl-Module-Build
+ test? ( dev-perl/Test-Deep )"
+
+want_apache2 modperl
+
+SRC_TEST="do"
+mydoc="CREDITS UPGRADE"
+myconf="--noprompts"
+
+pkg_setup() {
+ depend.apache_pkg_setup modperl
+ perl-module_pkg_setup
+}
+
+perl-module_src_prep() {
+ # Note about new modperl use flag
+ if use !modperl ; then
+ ewarn "HTML-Mason will only install with modperl support"
+ ewarn "if the use flag modperl is enabled."
+ sleep 5
+ fi
+ # rendhalver - needed to set an env var for the build script so it finds our apache.
+ APACHE="${APACHE_BIN}" perl "${S}"/Build.PL installdirs=vendor destdir="${D}" ${myconf}
+}
+
+src_install () {
+ perl-module_src_install
+ # rendhalver - the html docs have subdirs so this gets all of them
+ use doc && dohtml -r htdocs/*
+}