summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-08-25 17:21:00 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-08-25 17:21:00 +0000
commitdc1ff5243a4c61d87a54d6a52604bf9351d2546a (patch)
tree1e54747351cf0da48d78457fd21967d6a9937dfd /dev-perl/DBD-Pg/DBD-Pg-2.15.1.ebuild
parentVersion bump via perl-bump experimental tool. (diff)
downloadgentoo-2-dc1ff5243a4c61d87a54d6a52604bf9351d2546a.tar.gz
gentoo-2-dc1ff5243a4c61d87a54d6a52604bf9351d2546a.tar.bz2
gentoo-2-dc1ff5243a4c61d87a54d6a52604bf9351d2546a.zip
Version bump via perl-bump experimental tool.
(Portage version: 2.2_rc38/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/DBD-Pg/DBD-Pg-2.15.1.ebuild')
-rw-r--r--dev-perl/DBD-Pg/DBD-Pg-2.15.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-perl/DBD-Pg/DBD-Pg-2.15.1.ebuild b/dev-perl/DBD-Pg/DBD-Pg-2.15.1.ebuild
new file mode 100644
index 000000000000..fc5914d93af2
--- /dev/null
+++ b/dev-perl/DBD-Pg/DBD-Pg-2.15.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/DBD-Pg/DBD-Pg-2.15.1.ebuild,v 1.1 2009/08/25 17:21:00 robbat2 Exp $
+
+MODULE_AUTHOR=TURNSTEP
+inherit perl-module eutils
+
+DESCRIPTION="The Perl DBD::Pg Module"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="virtual/perl-Test-Simple
+ virtual/perl-version
+ >=virtual/perl-Test-Harness-2.03
+ >=dev-perl/DBI-1.52
+ >=virtual/postgresql-base-7.3"
+
+mydoc="README"
+
+# testcases require a local database with an
+# open password for the postgres user.
+SRC_TEST="skip"
+
+src_compile() {
+ postgres_include="$(readlink -f /usr/include/postgresql)"
+ postgres_lib="${postgres_include//include/lib}"
+ # Fall-through case is the non-split postgresql
+ # The active cases instead get us the matching libdir for the includedir.
+ for i in lib lib64 ; do
+ if [ -d ${postgres_lib}/${i} ]; then
+ postgres_lib="${postgres_lib}/${i}"
+ break
+ fi
+ done
+
+ # env variables for compilation:
+ export POSTGRES_INCLUDE="${postgres_include}"
+ export POSTGRES_LIB="${postgres_lib}"
+ perl-module_src_compile
+}