summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-01-07 11:31:50 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-01-07 11:31:50 +0000
commitfad25a223f73dc95ab619c70ed3dc68967cbc6c2 (patch)
treee0795a74c5ea2da9f258278e3bad164dcb3b100f /dev-ml
parentpgasync is a Python library and not a standalone application. Moved from dev-... (diff)
downloadgentoo-2-fad25a223f73dc95ab619c70ed3dc68967cbc6c2.tar.gz
gentoo-2-fad25a223f73dc95ab619c70ed3dc68967cbc6c2.tar.bz2
gentoo-2-fad25a223f73dc95ab619c70ed3dc68967cbc6c2.zip
version bump
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/cryptokit/ChangeLog9
-rw-r--r--dev-ml/cryptokit/cryptokit-1.10.ebuild49
2 files changed, 56 insertions, 2 deletions
diff --git a/dev-ml/cryptokit/ChangeLog b/dev-ml/cryptokit/ChangeLog
index 2bca3e6886d2..e5de23d3efbe 100644
--- a/dev-ml/cryptokit/ChangeLog
+++ b/dev-ml/cryptokit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/cryptokit
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/cryptokit/ChangeLog,v 1.26 2014/03/13 19:54:26 aballier Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/cryptokit/ChangeLog,v 1.27 2015/01/07 11:31:50 aballier Exp $
+
+*cryptokit-1.10 (07 Jan 2015)
+
+ 07 Jan 2015; Alexis Ballier <aballier@gentoo.org> +cryptokit-1.10.ebuild:
+ version bump
*cryptokit-1.9 (13 Mar 2014)
diff --git a/dev-ml/cryptokit/cryptokit-1.10.ebuild b/dev-ml/cryptokit/cryptokit-1.10.ebuild
new file mode 100644
index 000000000000..7fab6c9f1c29
--- /dev/null
+++ b/dev-ml/cryptokit/cryptokit-1.10.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/cryptokit/cryptokit-1.10.ebuild,v 1.1 2015/01/07 11:31:50 aballier Exp $
+
+EAPI="5"
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="Cryptographic primitives library for Objective Caml"
+HOMEPAGE="http://forge.ocamlcore.org/projects/cryptokit/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/1493/${P}.tar.gz"
+LICENSE="LGPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="zlib"
+
+DEPEND="zlib? ( >=sys-libs/zlib-1.1 )"
+RDEPEND="${DEPEND}"
+
+DOCS=( "Changes" "README.txt" "AUTHORS.txt" )
+
+src_configure() {
+ oasis_configure_opts="$(use_enable zlib)" \
+ oasis_src_configure
+}
+
+pkg_postinst() {
+ elog ""
+ elog "This library uses the /dev/random device to generate "
+ elog "random data and RSA keys. The device should either be"
+ elog "built into the kernel or provided as a module. An"
+ elog "alternative is to use the Entropy Gathering Daemon"
+ elog "(http://egd.sourceforge.net). Please note that the"
+ elog "remainder of the library will still work even in the"
+ elog "absence of a one of these sources of randomness."
+ elog ""
+}
+
+src_test() {
+ echo ""
+ einfo "You must have either /dev/random or the Entropy Gathering"
+ einfo "Daemon (EGD) for this test to succeed!"
+ echo ""
+
+ oasis_src_test
+}