summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-10-22 20:45:45 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-10-22 20:45:45 +0000
commitd797d389148040ba33e06c0a28c9de0d4eb9d3cf (patch)
tree449a51a1c0155f6003363f8b0b5d87b8ee1022f7 /dev-ml
parentdo not compress .dvi files as they are used by advi and unreadable compressed (diff)
downloadgentoo-2-d797d389148040ba33e06c0a28c9de0d4eb9d3cf.tar.gz
gentoo-2-d797d389148040ba33e06c0a28c9de0d4eb9d3cf.tar.bz2
gentoo-2-d797d389148040ba33e06c0a28c9de0d4eb9d3cf.zip
version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/camlimages/ChangeLog7
-rw-r--r--dev-ml/camlimages/camlimages-4.1.1.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/dev-ml/camlimages/ChangeLog b/dev-ml/camlimages/ChangeLog
index bd3b989161bc..d243865a5030 100644
--- a/dev-ml/camlimages/ChangeLog
+++ b/dev-ml/camlimages/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/camlimages
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlimages/ChangeLog,v 1.36 2013/05/24 15:46:20 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlimages/ChangeLog,v 1.37 2013/10/22 20:45:45 aballier Exp $
+
+*camlimages-4.1.1 (22 Oct 2013)
+
+ 22 Oct 2013; Alexis Ballier <aballier@gentoo.org> +camlimages-4.1.1.ebuild:
+ version bump
24 May 2013; Alexis Ballier <aballier@gentoo.org> camlimages-4.0.1.ebuild:
eapi5, define subslot and add slot dep on ocaml
diff --git a/dev-ml/camlimages/camlimages-4.1.1.ebuild b/dev-ml/camlimages/camlimages-4.1.1.ebuild
new file mode 100644
index 000000000000..9aa22fc7ff32
--- /dev/null
+++ b/dev-ml/camlimages/camlimages-4.1.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlimages/camlimages-4.1.1.ebuild,v 1.1 2013/10/22 20:45:45 aballier Exp $
+
+EAPI=5
+
+inherit eutils vcs-snapshot findlib multilib
+
+DESCRIPTION="An image manipulation library for ocaml"
+HOMEPAGE="http://gallium.inria.fr/camlimages/"
+SRC_URI="http://bitbucket.org/camlspotter/camlimages/get/${PV}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc exif gif gtk jpeg png postscript tiff truetype X xpm"
+
+RDEPEND=">=dev-lang/ocaml-3.10.2:=[X?,ocamlopt]
+ exif? ( media-libs/libexif )
+ gif? ( media-libs/giflib )
+ gtk? ( dev-ml/lablgtk )
+ jpeg? ( virtual/jpeg )
+ tiff? ( media-libs/tiff )
+ png? ( >=media-libs/libpng-1.4:0 )
+ postscript? ( app-text/ghostscript-gpl )
+ truetype? ( >=media-libs/freetype-2 )
+ xpm? ( x11-libs/libXpm )
+ X? ( x11-apps/rgb )
+ sys-libs/zlib
+ "
+DEPEND="${DEPEND}
+ doc? ( dev-python/sphinx[latex] )
+ dev-util/omake
+ virtual/pkgconfig
+ dev-ml/findlib"
+
+camlimages_arg_want() {
+ echo "ARG_WANT_${2}=$(usex $1 1 0)"
+}
+
+src_compile() {
+ omake \
+ $(camlimages_arg_want exif EXIF ) \
+ $(camlimages_arg_want gif GIF ) \
+ $(camlimages_arg_want png PNG ) \
+ $(camlimages_arg_want jpeg JPEG ) \
+ $(camlimages_arg_want tiff TIFF ) \
+ $(camlimages_arg_want xpm XPM ) \
+ $(camlimages_arg_want postscript GS ) \
+ $(camlimages_arg_want gtk LABLGTK2) \
+ $(camlimages_arg_want X GRAPHICS) \
+ $(camlimages_arg_want truetype FREETYPE) \
+ --force-dotomake || die
+
+ if use doc ; then
+ sphinx-build doc/sphinx sphinxdoc || die
+ fi
+}
+
+src_install() {
+ findlib_src_preinst
+ omake --force-dotomake DESTDIR="${D}" install || die
+ dodoc README.rst
+ use doc && dohtml -r sphinxdoc/*
+}