summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-07-30 18:57:16 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-07-30 18:57:16 +0000
commitbd62e5fb397d10a254e9ef2543afe0435c6713b5 (patch)
tree17fec432c2854a798182db408ccc6083bfa28c0a /dev-ml
parentia64 stable wrt bug #533350 (diff)
downloadgentoo-2-bd62e5fb397d10a254e9ef2543afe0435c6713b5.tar.gz
gentoo-2-bd62e5fb397d10a254e9ef2543afe0435c6713b5.tar.bz2
gentoo-2-bd62e5fb397d10a254e9ef2543afe0435c6713b5.zip
version bump
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/camlp5/ChangeLog7
-rw-r--r--dev-ml/camlp5/camlp5-6.14.ebuild67
2 files changed, 73 insertions, 1 deletions
diff --git a/dev-ml/camlp5/ChangeLog b/dev-ml/camlp5/ChangeLog
index c1461a8a9997..d5dcd7dcbe36 100644
--- a/dev-ml/camlp5/ChangeLog
+++ b/dev-ml/camlp5/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/camlp5
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/ChangeLog,v 1.88 2015/06/18 08:42:51 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/ChangeLog,v 1.89 2015/07/30 18:57:16 aballier Exp $
+
+*camlp5-6.14 (30 Jul 2015)
+
+ 30 Jul 2015; Alexis Ballier <aballier@gentoo.org> +camlp5-6.14.ebuild:
+ version bump
18 Jun 2015; Alexis Ballier <aballier@gentoo.org> -camlp5-6.11.ebuild:
remove old
diff --git a/dev-ml/camlp5/camlp5-6.14.ebuild b/dev-ml/camlp5/camlp5-6.14.ebuild
new file mode 100644
index 000000000000..bacf6cc38f73
--- /dev/null
+++ b/dev-ml/camlp5/camlp5-6.14.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/camlp5-6.14.ebuild,v 1.1 2015/07/30 18:57:16 aballier Exp $
+
+EAPI="5"
+
+inherit multilib findlib eutils
+
+MY_P=${P%_p*}
+DESCRIPTION="A preprocessor-pretty-printer of ocaml"
+HOMEPAGE="http://camlp5.gforge.inria.fr/"
+SRC_URI="http://camlp5.gforge.inria.fr/distrib/src/${MY_P}.tgz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="doc +ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-3.10:=[ocamlopt?]"
+RDEPEND="${DEPEND}"
+
+PATCHLEVEL=${PV#*_p}
+PATCHLIST=""
+
+if [ "${PATCHLEVEL}" != "${PV}" ] ; then
+ for (( i=1; i<=PATCHLEVEL; i++ )) ; do
+ SRC_URI="${SRC_URI}
+ http://pauillac.inria.fr/~ddr/camlp5/distrib/src/patch-${PV%_p*}-${i} -> ${MY_P}-patch-${i}.patch"
+ PATCHLIST="${PATCHLIST} ${MY_P}-patch-${i}.patch"
+ done
+fi
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ for i in ${PATCHLIST} ; do
+ epatch "${DISTDIR}/${i}"
+ done
+}
+
+src_configure() {
+ ./configure \
+ --strict \
+ -prefix /usr \
+ -bindir /usr/bin \
+ -libdir /usr/$(get_libdir)/ocaml \
+ -mandir /usr/share/man || die "configure failed"
+}
+
+src_compile(){
+ emake out
+ if use ocamlopt; then
+ emake opt
+ emake opt.opt
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ # findlib support
+ insinto "$(ocamlfind printconf destdir)/${PN}"
+ doins etc/META
+
+ use doc && dohtml -r doc/*
+
+ dodoc CHANGES DEVEL ICHANGES README UPGRADING MODE
+}