summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-10-13 07:03:58 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-10-13 07:03:58 +0000
commitb8c0356b5bd450e9ebe42c7fa3f8fe2ca166601a (patch)
treec3703ad0d6665d44130960fa4f045c70c0c5f429 /dev-ml
parentversion bump (diff)
downloadgentoo-2-b8c0356b5bd450e9ebe42c7fa3f8fe2ca166601a.tar.gz
gentoo-2-b8c0356b5bd450e9ebe42c7fa3f8fe2ca166601a.tar.bz2
gentoo-2-b8c0356b5bd450e9ebe42c7fa3f8fe2ca166601a.zip
version bump
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/postgresql-ocaml/ChangeLog8
-rw-r--r--dev-ml/postgresql-ocaml/postgresql-ocaml-1.12.3.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-ml/postgresql-ocaml/ChangeLog b/dev-ml/postgresql-ocaml/ChangeLog
index 7106691d4df0..6fe427168a7f 100644
--- a/dev-ml/postgresql-ocaml/ChangeLog
+++ b/dev-ml/postgresql-ocaml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/postgresql-ocaml
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/ChangeLog,v 1.12 2009/09/28 18:57:18 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/ChangeLog,v 1.13 2009/10/13 07:03:58 aballier Exp $
+
+*postgresql-ocaml-1.12.3 (13 Oct 2009)
+
+ 13 Oct 2009; Alexis Ballier <aballier@gentoo.org>
+ +postgresql-ocaml-1.12.3.ebuild:
+ version bump
28 Sep 2009; Alexis Ballier <aballier@gentoo.org>
-postgresql-ocaml-1.8.2.ebuild, -postgresql-ocaml-1.11.1.ebuild:
diff --git a/dev-ml/postgresql-ocaml/postgresql-ocaml-1.12.3.ebuild b/dev-ml/postgresql-ocaml/postgresql-ocaml-1.12.3.ebuild
new file mode 100644
index 000000000000..f7bb94d647f6
--- /dev/null
+++ b/dev-ml/postgresql-ocaml/postgresql-ocaml-1.12.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/postgresql-ocaml-1.12.3.ebuild,v 1.1 2009/10/13 07:03:58 aballier Exp $
+
+EAPI="2"
+
+inherit findlib eutils
+
+IUSE="examples +ocamlopt"
+
+DESCRIPTION="A package for ocaml that provides access to PostgreSQL databases."
+SRC_URI="http://ocaml.info/ocaml_sources/${P}.tar.gz"
+HOMEPAGE="http://ocaml.info/home/ocaml_sources.html#toc9"
+
+DEPEND=">=dev-lang/ocaml-3.11[ocamlopt?]
+ >=virtual/postgresql-base-7.3
+ >=virtual/postgresql-server-7.3"
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+src_compile() {
+ cd "${S}/lib"
+ emake -j1 byte-code-library || die "failed to build byte code library"
+ if use ocamlopt; then
+ emake -j1 native-code-library || die "failed to built nativde code library"
+ fi
+}
+
+src_install () {
+ use ocamlopt || export OCAMLFIND_INSTFLAGS="-optional"
+ findlib_src_preinst
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS Changelog README.txt
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}