summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2004-08-21 21:55:57 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2004-08-21 21:55:57 +0000
commita1c35f514f54241160b5ce6bb4fe56fb4ade697e (patch)
tree78c13ab5ea313b65fbc62d87a8c9e03220ae44d0 /dev-ml
parentMinor fixes in dev-ml (diff)
downloadgentoo-2-a1c35f514f54241160b5ce6bb4fe56fb4ade697e.tar.gz
gentoo-2-a1c35f514f54241160b5ce6bb4fe56fb4ade697e.tar.bz2
gentoo-2-a1c35f514f54241160b5ce6bb4fe56fb4ade697e.zip
Adapt to findlib eclass, fix IUSE missing.
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ounit/ChangeLog5
-rw-r--r--dev-ml/ounit/ounit-1.0.0.ebuild17
2 files changed, 11 insertions, 11 deletions
diff --git a/dev-ml/ounit/ChangeLog b/dev-ml/ounit/ChangeLog
index 4e6953f8e8db..6f573fecb2a9 100644
--- a/dev-ml/ounit/ChangeLog
+++ b/dev-ml/ounit/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ml/ounit
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ounit/ChangeLog,v 1.1 2004/08/18 12:17:33 mattam Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ounit/ChangeLog,v 1.2 2004/08/21 21:55:57 mattam Exp $
+
+ 21 Aug 2004; Matthieu Sozeau <mattam@gentoo.org> ounit-1.0.0.ebuild:
+ Adapt to findlib eclass.
*ounit-1.0.0 (18 Aug 2004)
diff --git a/dev-ml/ounit/ounit-1.0.0.ebuild b/dev-ml/ounit/ounit-1.0.0.ebuild
index edf1942f8965..c76cda20b74a 100644
--- a/dev-ml/ounit/ounit-1.0.0.ebuild
+++ b/dev-ml/ounit/ounit-1.0.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ounit/ounit-1.0.0.ebuild,v 1.2 2004/08/18 17:48:42 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ounit/ounit-1.0.0.ebuild,v 1.3 2004/08/21 21:55:57 mattam Exp $
+
+inherit findlib
DESCRIPTION="Unit testing framework for OCaml"
HOMEPAGE="http://home.wanadoo.nl/maas/ocaml/"
@@ -8,21 +10,16 @@ SRC_URI="http://home.wanadoo.nl/maas/ocaml/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~x86 ~ppc"
-DEPEND="dev-lang/ocaml
- dev-ml/findlib"
+DEPEND="dev-lang/ocaml"
+IUSE=""
src_compile() {
emake all allopt || die "emake failed"
}
src_install() {
- # which directory does the lib go into?
- destdir=`ocamlfind printconf destdir`
- # install
- mkdir -p ${D}${destdir} || die
- make \
- OCAMLFIND_DESTDIR=${D}${destdir} \
- OCAMLFIND_LDCONF=dummy install || die
+ findlib_src_install
+
# typo
mv LICENCE LICENSE
# install documentation