summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-01-19 10:13:18 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-01-19 10:13:18 +0000
commit95135f91555b096087085dc1f1a1116818cc05b3 (patch)
tree712e6dc3075712ba56cec53f512fc7f1b41397e8 /dev-ml
parentversion bump (diff)
downloadgentoo-2-95135f91555b096087085dc1f1a1116818cc05b3.tar.gz
gentoo-2-95135f91555b096087085dc1f1a1116818cc05b3.tar.bz2
gentoo-2-95135f91555b096087085dc1f1a1116818cc05b3.zip
version bump
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/pxp/ChangeLog9
-rw-r--r--dev-ml/pxp/pxp-1.2.7.ebuild51
2 files changed, 58 insertions, 2 deletions
diff --git a/dev-ml/pxp/ChangeLog b/dev-ml/pxp/ChangeLog
index b7f58a724ea9..c6e09b33a447 100644
--- a/dev-ml/pxp/ChangeLog
+++ b/dev-ml/pxp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/pxp
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/pxp/ChangeLog,v 1.37 2014/11/28 17:57:23 aballier Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pxp/ChangeLog,v 1.38 2015/01/19 10:13:18 aballier Exp $
+
+*pxp-1.2.7 (19 Jan 2015)
+
+ 19 Jan 2015; Alexis Ballier <aballier@gentoo.org> +pxp-1.2.7.ebuild:
+ version bump
28 Nov 2014; Alexis Ballier <aballier@gentoo.org> pxp-1.2.4.ebuild:
update deps for ocaml 4.02
diff --git a/dev-ml/pxp/pxp-1.2.7.ebuild b/dev-ml/pxp/pxp-1.2.7.ebuild
new file mode 100644
index 000000000000..143b33c30d31
--- /dev/null
+++ b/dev-ml/pxp/pxp-1.2.7.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pxp/pxp-1.2.7.ebuild,v 1.1 2015/01/19 10:13:18 aballier Exp $
+
+EAPI="5"
+
+inherit findlib eutils
+
+MY_P=${P/_beta/test}
+
+DESCRIPTION="validating XML parser library for O'Caml"
+HOMEPAGE="http://projects.camlcity.org/projects/pxp.html"
+SRC_URI="http://download.camlcity.org/download/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+SLOT="0/${PV}"
+DEPEND=">=dev-ml/pcre-ocaml-4.31:=
+ >=dev-ml/ulex-0.5:=
+ >=dev-ml/ocamlnet-0.98:=
+ >=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ || ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )"
+RDEPEND="${DEPEND}"
+
+IUSE="examples +ocamlopt"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ #the included configure does not support many standard switches and is quite picky
+ ./configure || die "configure failed"
+}
+
+src_compile() {
+ emake -j1 all
+ if use ocamlopt; then
+ emake -j1 opt
+ fi
+}
+
+src_install() {
+ findlib_src_install
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ cd doc
+ dodoc ABOUT-FINDLIB README SPEC design.txt
+}